View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000700Ecere SDKgui/gfx-driver:x11public2012-03-27 19:472014-07-17 16:24
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000700: Window sizing issues on some X servers
DescriptionOn some X servers (e.g. Mac OS X Leopard's X11 and XMing), windows (probably without size specified: minClientSize only) show up with 0,0 client size
TagsNo tags attached.
Attached Files

- Relationships
related to 0000795closedjerome window not coming up right away in Mint 14 (have to click twice on Task Bar) 
related to 0000850closedjerome Ubuntu/Unity bug: Quirks with integration with top bar 

-  Notes
(0000694)
jerome (administrator)
2013-04-24 03:05

I've noticed twm suffers from this issues too.
Right now we have #ifdef for __APPLE__, and those fixe the twm usability.

Perhaps we should always be doing things this way. Does it break usability on other WMs?

Unity doesn't work so well. And neither does Cinnamon on Mint 14 either.
(0001013)
redj (administrator)
2013-08-28 15:53
edited on: 2013-08-28 15:56

https://github.com/ecere/ecere-sdk/commit/a8ddff1fc4599dc5a4b9b44caa1f48b81efa1eeb [^]

(0001056)
jerome (administrator)
2013-09-09 03:24
edited on: 2013-09-10 18:38

(hopefully) properly fixed by:

https://github.com/ecere/ecere-sdk/commit/da26fae0dbd8ec5aed46865f293aabdd15e5a5f0 [^]

and

https://github.com/ecere/ecere-sdk/commit/e8fa9cb4f6cdd043ab16ba0b3550b76be50dae54 [^]

(0001087)
jerome (administrator)
2013-09-29 00:04

Closing this issue as it now seems to be behaving properly.

- Issue History
Date Modified Username Field Change
2012-03-27 19:47 jerome New Issue
2012-03-29 07:53 redj Category => Ecere Runtime Library
2012-03-29 07:53 redj Project @1@ => Ecere SDK
2013-04-24 03:05 jerome Note Added: 0000694
2013-04-24 03:41 redj Relationship added related to 0000795
2013-04-24 03:41 redj Category ecere => gui/gfx-driver:x11
2013-06-17 18:03 jerome Status new => assigned
2013-06-17 18:03 jerome Assigned To => redj
2013-08-07 02:34 jerome Target Version 0.44.10 64 => 0.44.08
2013-08-09 10:54 jerome Target Version 0.44.08 => 0.44.10 64
2013-08-16 18:49 jerome Target Version 0.44.10 64 => 0.44.09
2013-08-28 15:53 redj Status assigned => resolved
2013-08-28 15:53 redj Fixed in Version => 0.44.09
2013-08-28 15:53 redj Resolution open => fixed
2013-08-28 15:53 redj Note Added: 0001013
2013-08-28 15:56 redj Note Edited: 0001013
2013-08-28 17:26 jerome Status resolved => closed
2013-09-09 03:22 jerome Assigned To redj => jerome
2013-09-09 03:22 jerome Resolution fixed => reopened
2013-09-09 03:22 jerome Fixed in Version 0.44.09 =>
2013-09-09 03:22 jerome Target Version 0.44.09 => 0.44.10 64
2013-09-09 03:22 jerome Status closed => assigned
2013-09-09 03:24 jerome Note Added: 0001056
2013-09-09 03:25 jerome Status assigned => resolved
2013-09-09 03:25 jerome Resolution reopened => fixed
2013-09-10 18:38 jerome Note Edited: 0001056
2013-09-29 00:04 jerome Status resolved => closed
2013-09-29 00:04 jerome Note Added: 0001087
2013-09-29 00:04 jerome Fixed in Version => 0.44.10 64
2014-07-17 16:24 jerome Relationship added related to 0000850



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker