View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000795Ecere SDKgui/gfx-driver:x11public2013-04-24 03:412014-08-08 18:17
Reporterredj 
Assigned Tojerome 
PriorityimmediateSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.07 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000795: window not coming up right away in Mint 14 (have to click twice on Task Bar)
DescriptionWindow not coming up right away in Mint 14 (have to click twice on Task Bar)
TagsNo tags attached.
Attached Files

- Relationships
related to 0000700closedjerome Window sizing issues on some X servers 
related to 0000850closedjerome Ubuntu/Unity bug: Quirks with integration with top bar 

-  Notes
(0000905)
redj (administrator)
2013-06-17 21:45

this alone will fix the problem with the window showing up invisible at first
#if 0 //!defined(__APPLE__) && !defined(__FreeBSD__)
            // TODO: How to handle frame extents not supported?
            if(!windowData.gotFrameExtents || window.state == maximized) return;
#endif
(0000926)
jerome (administrator)
2013-07-02 22:47

As part of the fixes for 0000700 and 0000795, these X error messages must be fixed:

X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
X Error: BadWindow (invalid Window parameter)
(0001016)
redj (administrator)
2013-08-28 15:55
edited on: 2013-08-28 15:56

https://github.com/ecere/ecere-sdk/commit/a8ddff1fc4599dc5a4b9b44caa1f48b81efa1eeb [^]

(0001055)
jerome (administrator)
2013-09-09 03:24
edited on: 2013-09-10 18:39

(hopefully) properly fixed by:

https://github.com/ecere/ecere-sdk/commit/da26fae0dbd8ec5aed46865f293aabdd15e5a5f0 [^]

(0001088)
jerome (administrator)
2013-09-29 00:04

Closing this issue as it now seems to be behaving properly.
(0001218)
jerome (administrator)
2014-04-29 12:13

This is a problem again on Mint 14 since:

https://github.com/jerstlouis/ecere-sdk/commits/e73c326886132254e338b7d6813009be6be84d6e [^]
(0001359)
jerome (administrator)
2014-07-07 20:12

Fixed by:
https://github.com/ecere/ecere-sdk/commit/b00bbe49bfce2a855c742305c4570953306eae57 [^]

- Issue History
Date Modified Username Field Change
2013-04-24 03:41 redj New Issue
2013-04-24 03:41 redj Relationship added related to 0000700
2013-04-24 20:19 jerome Priority normal => immediate
2013-06-17 18:03 jerome Status new => assigned
2013-06-17 18:03 jerome Assigned To => redj
2013-06-17 21:45 redj Note Added: 0000905
2013-07-02 22:47 jerome Note Added: 0000926
2013-08-07 02:33 jerome Target Version 0.44.10 64 => 0.44.08
2013-08-09 10:54 jerome Target Version 0.44.08 => 0.44.10 64
2013-08-16 18:49 jerome Target Version 0.44.10 64 => 0.44.09
2013-08-28 15:55 redj Status assigned => resolved
2013-08-28 15:55 redj Fixed in Version => 0.44.09
2013-08-28 15:55 redj Resolution open => fixed
2013-08-28 15:55 redj Note Added: 0001015
2013-08-28 15:55 redj Note Deleted: 0001015
2013-08-28 15:55 redj Note Added: 0001016
2013-08-28 15:56 redj Note Edited: 0001016
2013-08-28 17:26 jerome Status resolved => closed
2013-09-09 03:23 jerome Assigned To redj => jerome
2013-09-09 03:23 jerome Status closed => assigned
2013-09-09 03:23 jerome Resolution fixed => reopened
2013-09-09 03:23 jerome Fixed in Version 0.44.09 =>
2013-09-09 03:23 jerome Target Version 0.44.09 => 0.44.10 64
2013-09-09 03:24 jerome Status assigned => resolved
2013-09-09 03:24 jerome Fixed in Version => 0.44.10 64
2013-09-09 03:24 jerome Resolution reopened => fixed
2013-09-09 03:24 jerome Note Added: 0001055
2013-09-10 18:39 jerome Note Edited: 0001055
2013-09-10 18:39 jerome Note Edited: 0001055
2013-09-29 00:04 jerome Status resolved => closed
2013-09-29 00:04 jerome Note Added: 0001088
2014-04-29 12:13 jerome Note Added: 0001218
2014-04-29 12:13 jerome Status closed => assigned
2014-07-07 20:12 jerome Note Added: 0001359
2014-07-07 20:12 jerome Status assigned => resolved
2014-07-17 16:24 jerome Relationship added related to 0000850
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker