View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000850Ecere SDKgui/gfx-driver:x11public2013-04-24 13:472014-08-08 18:17
Reporterredj 
Assigned Tojerome 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.07 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000850: Ubuntu/Unity bug: Quirks with integration with top bar
DescriptionThe menu bar will show up twice, or display not where it responds to clicks
Steps To Reproduceopen ide
de-maximize
click menu -- not poping up
re-maximize
click menu -- double menu bar
Version: 7.0.0daily13.04.18~13.04-0ubuntu1
Additional InformationTry Printing out ExternalPosition, state =, DesktopResized events
TagsNo tags attached.
Attached Filespng file icon unityBug.png [^] (212,098 bytes) 2013-08-23 17:55

- Relationships
related to 0000795closedjerome window not coming up right away in Mint 14 (have to click twice on Task Bar) 
related to 0000700closedjerome Window sizing issues on some X servers 

-  Notes
(0000994)
jerome (administrator)
2013-08-23 18:03

Unity bugs/dev-list:

https://launchpad.net/~unity-dev [^]

IRC channel: #ubunutu-unity on Freenode

-------
Track down PropertyNotify of _NET_FRAME_EXTENTS

Of particular interest:

if(!hadFrameExtents) // || window.state == normal)

This might prevent a change in frame extents.

And the fact that we only request the frame extents in a CreateWindow(), not on a maximize state change.
(0001017)
redj (administrator)
2013-08-28 16:13
edited on: 2013-08-28 16:13

https://github.com/ecere/ecere-sdk/commit/9e450460bfbceeb7b001c4b9a7cfcc3d50b1353c [^]

(0001031)
jerome (administrator)
2013-08-29 04:38

Further refined by

https://github.com/ecere/ecere-sdk/commit/1530d97f6d6dd0b8136b63e116f48a7ffece3b20 [^]
(0001051)
jerome (administrator)
2013-08-30 19:55

Still broken!!

Awareness of 'skinMenuHeight' might be to blame...

There really (confusingly) are 3 coordinate systems:

- 0,0 at top left of window with decorations
- 0,0 at client start, how OnRedraw() understands it
- 0,0 at top left of our actual X11 Window without its decorations, as X understands it

A proper translation might still be missing somewhere, but why does it work fine with everything else but Unity?
(0001054)
jerome (administrator)
2013-09-09 03:24
edited on: 2013-09-10 18:39

(hopefully) properly fixed by:

https://github.com/ecere/ecere-sdk/commit/da26fae0dbd8ec5aed46865f293aabdd15e5a5f0 [^]

(0001086)
jerome (administrator)
2013-09-29 00:04

Closing this issue as it now seems to be behaving properly.
(0001216)
jerome (administrator)
2014-04-28 20:52
edited on: 2014-04-28 21:08

Tweaked by:
https://github.com/ecere/ecere-sdk/commit/06217d4d40e18eb6b1489ec597780721bcc6a811 [^]

https://github.com/ecere/ecere-sdk/commit/e73c326886132254e338b7d6813009be6be84d6e [^]

This is *STILL* buggy.

- Start the IDE (it's maximized)
- Unmaximize
- Drag title bar (move)
- Maximize again

Mouse position is now off.

(0001217)
jerome (administrator)
2014-04-29 10:06
edited on: 2014-04-29 10:14

The major source of all these issues have been the convoluted decision in the ICCCM that x and y mean different things depending on the value of send_event:

http://tronche.com/gui/x/icccm/sec-4.html#s-4.1.5 [^]

This has been addressed by:
https://github.com/ecere/ecere-sdk/commit/2b79321f788a9da837e852e0155b7389f431953e [^]

A problem when unmaximizing through dragging the integrated title bar in the Ubuntu global menu bar was also found and fixed by:

https://github.com/ecere/ecere-sdk/commit/85ad13a7fd22eae3ed60f29ff69c912635a97dfb [^]

By disabling code previously added that no longer seems necessary.

(0001379)
jerome (administrator)
2014-07-16 15:11

There is still an issue 'unmaximizing' through dragging title bar on GNOME Classic (Metacity) -- as in note above though that seemed to apply to Unity.
(0001380)
jerome (administrator)
2014-07-17 18:47

Fixed by:
https://github.com/ecere/ecere-sdk/commit/56ac16728a5278bc2e8055cc83f8e2bfe788be8b [^]

- Issue History
Date Modified Username Field Change
2013-04-24 13:47 redj New Issue
2013-04-24 13:48 redj Category ecere => gui/gfx-driver:x11
2013-04-24 19:57 jerome Priority normal => immediate
2013-06-21 18:40 jerome Summary Ubuntu/Unity bug: Print out ExternalPosition, state =, DesktopResized events => Ubuntu/Unity bug: Quirks with integration with top bar
2013-06-21 18:40 jerome Description Updated
2013-06-21 18:40 jerome Additional Information Updated
2013-06-21 18:40 jerome Status new => assigned
2013-06-21 18:40 jerome Assigned To => redj
2013-06-28 22:31 redj Steps to Reproduce Updated
2013-06-28 22:34 redj Steps to Reproduce Updated
2013-08-16 18:49 jerome Target Version 0.44.10 64 => 0.44.09
2013-08-23 17:55 jerome File Added: unityBug.png
2013-08-23 18:03 jerome Note Added: 0000994
2013-08-28 16:13 redj Status assigned => resolved
2013-08-28 16:13 redj Fixed in Version => 0.44.09
2013-08-28 16:13 redj Resolution open => fixed
2013-08-28 16:13 redj Note Added: 0001017
2013-08-28 16:13 redj Note Edited: 0001017
2013-08-28 17:26 jerome Status resolved => closed
2013-08-29 04:38 jerome Note Added: 0001031
2013-08-30 19:53 jerome Status closed => assigned
2013-08-30 19:53 jerome Resolution fixed => reopened
2013-08-30 19:55 jerome Note Added: 0001051
2013-09-08 18:24 jerome Target Version 0.44.09 => 0.44.10 64
2013-09-09 03:24 jerome Status assigned => resolved
2013-09-09 03:24 jerome Fixed in Version 0.44.09 => 0.44.10 64
2013-09-09 03:24 jerome Resolution reopened => fixed
2013-09-09 03:24 jerome Note Added: 0001054
2013-09-10 02:11 jerome Status resolved => assigned
2013-09-10 02:11 jerome Assigned To redj => jerome
2013-09-10 02:11 jerome Status assigned => resolved
2013-09-10 18:39 jerome Note Edited: 0001054
2013-09-29 00:04 jerome Status resolved => closed
2013-09-29 00:04 jerome Note Added: 0001086
2014-04-28 20:52 jerome Note Added: 0001216
2014-04-28 20:52 jerome Status closed => assigned
2014-04-28 21:08 jerome Note Edited: 0001216
2014-04-28 21:34 jerome Severity minor => major
2014-04-29 10:06 jerome Note Added: 0001217
2014-04-29 10:14 jerome Note Edited: 0001217
2014-04-29 10:18 jerome Status assigned => resolved
2014-05-19 01:32 jerome Status resolved => closed
2014-07-16 15:11 jerome Note Added: 0001379
2014-07-16 15:11 jerome Status closed => assigned
2014-07-17 16:24 jerome Relationship added related to 0000795
2014-07-17 16:24 jerome Relationship added related to 0000700
2014-07-17 18:47 jerome Note Added: 0001380
2014-07-17 18:47 jerome Status assigned => resolved
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker