View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000059Ecere SDKidepublic2008-05-03 18:302012-03-29 07:52
Reporterrnsanchez 
Assigned Tojerome 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSSlackwareOS Version12.0
Product Version 
Target VersionFixed in Version 
Summary0000059: Ecere IDE using too much CPU upon File > Open
DescriptionWhile asking Ecere IDE to open file/project, it takes a great deal of CPU from the moment I click in the menu until the Open File dialog is presented. In order to see what's going on, I strace'd it as:

    $ strace -o file_open.log ide

The resulting log is attached.
Additional InformationVim has strace syntax highlighting, very helpful given the size of the log (:set ft=strace).
TagsNo tags attached.
Attached Filesgz file icon file_open.log.gz [^] (115,386 bytes) 2008-05-03 22:19

- Relationships
child of 0000433closed previously resolved issues (draft 1 of 0.44 and earlier) 

-  Notes
(0000027)
jerome (administrator)
2008-05-05 19:51

The log is filled up with "EAGAIN (Resource temporarily unavailable)" which is usually caused by network resources being disconnected or the like...

In what directory did the Open File dialog open?
Are there any remote resources within that directory?

Does this happen all the time for you, can you reproduce it easily?

(0000030)
rnsanchez (reporter)
2008-05-06 03:04

The Open File dialog opened at my home (/home/rnsanchez). There's no reason to exist network activity on that box, as there's no NFS or anything alike. I'll check it further, ASAP.

It happens all the time, and not only in the Open File dialog. Most combo boxes (like the one in Project > Settings) show up a considerable lag between click and window response, and the CPU usage in those moments is pretty high---so high that sometimes the whole X session freezes for brief moments.

I'll try to provide further strace logs with different activities.
(0000031)
jerome (administrator)
2008-05-06 03:14
edited on: 2008-05-06 03:14

This might also be related to processing the unicode fonts...
Do you have non standard characters in there to be displayed?
But this EAGAIN error definitely says "resource temporarily not available" ...
So maybe your fontconfig has some wrong paths in there?

(0000033)
rnsanchez (reporter)
2008-05-06 14:06

I don't think there was any odd character (opening HelloWorld example in the home directory).

There are some dead fontpahts, though. Wouldn't this harm other applications?

I should test it again soon (probably this afternoon, ~ now + 3 hours).
(0000036)
jerome (administrator)
2008-05-11 02:07

The problem was the runtime library using shared memory pixmaps by default, along with X calls which can not be accelerated for shared memory pixmaps.

It is not clear if there ever was a performance improvement from using shared memory on a different system. Shared memory pixmaps are now disabled by default, and Window and Display properties were added to enable them. An LFB software implementation for the X driver (rather than using X call) could be written in an attempt to speed it up.

- Issue History
Date Modified Username Field Change
2008-05-03 18:30 rnsanchez New Issue
2008-05-03 22:19 rnsanchez File Added: file_open.log.gz
2008-05-05 19:51 jerome Note Added: 0000027
2008-05-05 19:51 jerome Status new => feedback
2008-05-06 03:04 rnsanchez Note Added: 0000030
2008-05-06 03:14 jerome Note Added: 0000031
2008-05-06 03:14 jerome Note Edited: 0000031
2008-05-06 14:06 rnsanchez Note Added: 0000033
2008-05-09 18:40 jerome Status feedback => assigned
2008-05-09 18:40 jerome Assigned To => jerome
2008-05-09 18:40 jerome Priority normal => high
2008-05-11 02:07 jerome Status assigned => resolved
2008-05-11 02:07 jerome Resolution open => fixed
2008-05-11 02:07 jerome Note Added: 0000036
2009-05-03 03:43 jerome Status resolved => closed
2010-07-25 21:54 redj Relationship added child of 0000433
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker