View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000133Ecere SDKidepublic2008-08-22 22:142012-03-29 07:52
Reporterrohypnol 
Assigned Tojerome 
PriorityimmediateSeverityblockReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000133: App not closing
DescriptionCreate a new project. Set borderStyle of Form1 to None. Set it back to Sizable. Run the application. Here are the behaviors I've got:
- IDE disappeared (eC completely crashed, no warning)
- The drop-down for borderStyle was positioned to 0, 0 on the screen (using one monitor) thus couldn't be changed
- The project doesn't appear to be running, you can run it again and you get a second Form1 application
- IDE can be closed with no warning that project changed and the Form1 app remaisn open
(and others)
If those two steps don't work, close the application, change the borderStyle a few times and go back to Sizable and run it again.

The application can't be closed with Alt+F4 any more as all applications should!
TagsNo tags attached.
Attached Files

- Relationships
child of 0000433closed previously resolved issues (draft 1 of 0.44 and earlier) 

-  Notes
(0000092)
jerome (administrator)
2008-08-29 20:50

NASTY BUG ON WINDOWS IN PROPERTIES SHEET IF WE DON'T RECREATE THE LISTBOX HERE
To reproduce, comment out, select borderStyle property, alt-tab to another program, come back, drop down. The listBox goes annoyingly to 0, 0.

Added this to DropBox::OnDropDown() :

      // The listBox goes annoyingly to 0, 0
      listBox.Destroy(0);
      listBox.Create();

The crash seems fixed, could not reproduce with current code.

Windows wihout "hasClose" (the close button, which requires a fixed or resizeable border style) do not automatically close on Alt-F4. Extra code can be added in an OnKeyDown to check for key == altF4 and call Destroy().
(0000093)
jerome (administrator)
2008-08-29 20:56

I tried to reproduce the crash with ecere-win32-0.43.zip dated from 08/22 but was not able to either...

- Issue History
Date Modified Username Field Change
2008-08-22 22:14 rohypnol New Issue
2008-08-22 22:42 jerome Assigned To => jerome
2008-08-22 22:42 jerome Priority normal => immediate
2008-08-22 22:42 jerome Status new => assigned
2008-08-29 20:50 jerome Note Added: 0000092
2008-08-29 20:50 jerome Status assigned => resolved
2008-08-29 20:50 jerome Resolution open => fixed
2008-08-29 20:56 jerome Note Added: 0000093
2009-05-03 03:43 jerome Status resolved => closed
2010-07-25 21:28 redj Relationship added child of 0000429
2010-07-25 21:36 redj Relationship deleted child of 0000429
2010-07-25 21:36 redj Relationship added child of 0000433
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker