View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001075Ecere SDKidepublic2014-04-22 22:032014-05-19 01:33
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.09 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0001075: Hard to reproduce crash on closing project
DescriptionFinally spotted the random crash on closing a project
(Or the IDE, or opening a new project)

The crash is caused by configsNameCollisions having null entries left in it.

The difficulty to reproduce/figure out this crash is caused by the specific sequence of events (ProjectLoadLastBuildNamesInfo() must be called, e.g. by a Build(), and then ModifiedAllConfigs() must be called, by adding/removing files to the project.
Steps To Reproduce- Open a project
- Build (F7)
- Remove a file from the project (no need to save)
- Close the project or IDE
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001213)
jerome (administrator)
2014-04-23 03:29

Fixed by:
https://github.com/ecere/ecere-sdk/commit/ce99c9d0927926eda575ea5b3a6de4546aaae7d6 [^]

- Issue History
Date Modified Username Field Change
2014-04-22 22:03 jerome New Issue
2014-04-22 22:03 jerome Status new => assigned
2014-04-22 22:03 jerome Assigned To => jerome
2014-04-23 03:29 jerome Status assigned => resolved
2014-04-23 03:29 jerome Fixed in Version => 0.44.10 64
2014-04-23 03:29 jerome Resolution open => fixed
2014-04-23 03:29 jerome Note Added: 0001213
2014-05-19 01:33 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker