View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000975Ecere SDKide:buildsystempublic2013-08-07 07:242013-08-30 03:04
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.07 
Target Version0.44.09Fixed in Version0.44.09 
Summary0000975: Spaces don't work at all for files anymore, not even resources (This used to work!)
Description- Test with .ec module
- Test with Resources
Additional InformationOutput of building a project with "space test.ec":

Default Compiler
Rebuilding project spaceTest using the Debug configuration...
Target and object files deleted
Generating symbols...
space test.ec
   Syntax:
<input>
Compiling...
space test.ec
   Syntax:
<input>
space test.c
Writing symbol loader...
   gcc: error: obj/debug.win32/space\: No such file or directory
   gcc: error: test.c: No such file or directory
   gcc: error: test.o: No such file or directory
   gcc: fatal error: no input files
compilation terminated.

spaceTest.exe (Debug) - 4 errors, no warning



For resources in Installer:

Building project Installer using the Debug configuration...
   ../samples/db/MovieCollection/edapresentation.pptx: No such file or directory

TagsNo tags attached.
Attached Files

- Relationships
related to 0000996closedredj Remaining troubles with .ec modules containing spaces 

-  Notes
(0000981)
redj (administrator)
2013-08-08 19:55

regression fixed by
https://github.com/redj/ecere-sdk/commit/bc185d846501f88452959ec8be6f95bb15a4a1e4 [^]
https://github.com/redj/ecere-sdk/commit/a63ae82385dbe1519d6e6295ba423bed7e59bef1 [^]
(0000991)
redj (administrator)
2013-08-22 20:18

need to know what the heck we are supposed to do about this %%I thing or whatnot on windows so I can test this in windows...

unable to reproduce in linux
(0000992)
jerome (administrator)
2013-08-22 21:46

About %%I issue:

- Revert to before the nonsense WIN8 tweak I put in
- Use 177kb mingw32-make.exe:

GNU Make 3.82
Built for i686-w64-mingw32

(See email)
(0000993)
redj (administrator)
2013-08-23 12:12

currently unable to reproduce on both windows and linux
(0000995)
jerome (administrator)
2013-08-23 18:13
edited on: 2013-08-30 03:04

Using the latest TDM MinGW-w64 binaries and the latest make from MinGW-w64:

http://sourceforge.net/projects/mingw-w64/files/External%20binary%20packages%20%28Win64%20hosted%29/make/make-3.82.90-20111115.zip/download [^]

- Create a project, add a file with a space in it
- With a minimalistic compiler, it actually builds fine but suffers from a few issues:

   * A bunch of these error messages on clean/rebuild: E:/temp/spacetest2/spacetest2-Debug.Makefile:148: recipe for target `clean' failed
   * Ctrl-F7 (Compile single file still doesn't work)

Adding a path with space to the include paths, things don't build at all anymore, either of the following will cause the original problem:

C:\Program Files\Ecere SDK\tdm\lib\gcc\x86_64-w64-mingw32\4.7.1\include\c++
C:\Program Files (x86)\Java\jdk1.7.0_03\include

This aspect has been moved to 0000996


- Issue History
Date Modified Username Field Change
2013-08-07 07:24 jerome New Issue
2013-08-07 07:24 jerome Status new => assigned
2013-08-07 07:24 jerome Assigned To => redj
2013-08-08 19:55 redj Status assigned => resolved
2013-08-08 19:55 redj Fixed in Version => 0.44.08
2013-08-08 19:55 redj Resolution open => fixed
2013-08-08 19:55 redj Note Added: 0000981
2013-08-09 10:53 jerome Status resolved => assigned
2013-08-09 10:53 jerome Fixed in Version 0.44.08 =>
2013-08-09 10:53 jerome Target Version 0.44.08 => 0.44.10 64
2013-08-16 18:48 jerome Target Version 0.44.10 64 => 0.44.09
2013-08-22 20:18 redj Note Added: 0000991
2013-08-22 20:18 redj Status assigned => feedback
2013-08-22 21:46 jerome Note Added: 0000992
2013-08-22 21:46 jerome Status feedback => assigned
2013-08-23 12:12 redj Note Added: 0000993
2013-08-23 12:12 redj Status assigned => feedback
2013-08-23 18:13 jerome Note Added: 0000995
2013-08-23 18:13 jerome Status feedback => assigned
2013-08-23 18:14 jerome Note Edited: 0000995
2013-08-30 02:53 jerome Issue cloned: 0000996
2013-08-30 02:54 jerome Relationship added related to 0000996
2013-08-30 03:04 jerome Note Edited: 0000995
2013-08-30 03:04 jerome Status assigned => resolved
2013-08-30 03:04 jerome Fixed in Version => 0.44.09 64
2013-08-30 03:04 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker