View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000938Ecere SDKide:debuggerpublic2013-06-12 23:292013-08-09 10:53
Reporterredj 
Assigned Toredj 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.07 
Target Version0.44.08Fixed in Version0.44.08 
Summary0000938: gdb doesn't hit on a breakpoint in the beginning of main in x.main.ec when a bp is placed inside __ecere_COM_Initialize
Descriptionbp in instance.c hits and prevents bp in main (x.main.ec) from hitting.

old summary:
suspect user breakpoints are ignored if placed at same location as internal breakpoints


bp on
__thisModule = __currentModule = module = __ecere_COM_Initialize(1, _argc, (void *)_argv);

in .main.ec file will be ignored


same thing for
__ecereRegisterModule_ecp(module);
TagsNo tags attached.
Attached Files

- Relationships
related to 0000332closed Debugger Breakpoints Jammed (Initial Step over...) 
related to 0000986closedredj More troubles with initial internal breakpoints 

-  Notes
(0000902)
redj (administrator)
2013-06-17 20:00
edited on: 2013-06-17 20:04

if you set a breakpoint in Instance_COM_Initialize first, then the bp on __thisModule = __currentModule = module = __ecere_COM_Initialize(1, _argc, (void *)_argv); will not hit.

this seems to be an issue in gdb or in the information given to gdb by the #line directives in .c files perhaps?

I find this only occurs in the beginning of the main function in x.main.ec

will move this to target "Debug" issue and change priority to low.

(0000908)
redj (administrator)
2013-06-18 01:03

fixed by https://github.com/redj/ecere-sdk/commit/7eeb24abfa46462cba5dcbab568c5dd781f053d4 [^]
(0000915)
redj (administrator)
2013-06-28 22:43

Stepping over eModule_Load(module, "ecere", privateAccess); still doesn't work
And I think it's because it sees it as the internal breakpoint and just keeps going
not realizing it was a step over that was done
(0000983)
redj (administrator)
2013-08-08 20:04

https://github.com/redj/ecere-sdk/commit/98fe0afeaf4e98c40882e242d035827c7d2c32d9 [^]

- Issue History
Date Modified Username Field Change
2013-06-12 23:29 redj New Issue
2013-06-12 23:35 redj Description Updated
2013-06-12 23:36 redj Status new => assigned
2013-06-12 23:36 redj Assigned To => redj
2013-06-17 20:00 redj Note Added: 0000902
2013-06-17 20:00 redj Priority normal => low
2013-06-17 20:00 redj Target Version 0.44.10 64 => 0.44.50 Debug
2013-06-17 20:00 redj Note Edited: 0000902
2013-06-17 20:01 redj Assigned To redj =>
2013-06-17 20:04 redj Note Edited: 0000902
2013-06-17 20:06 redj Summary suspect user breakpoints are ignored if placed at same location as internal breakpoints => gdb doesn't hit on a breakpoint in the beginning of main in x.main.ec when a bp is placed inside __ecere_COM_Initialize
2013-06-17 20:06 redj Description Updated
2013-06-18 01:03 redj Status assigned => resolved
2013-06-18 01:03 redj Fixed in Version => 0.44.10 64
2013-06-18 01:03 redj Resolution open => fixed
2013-06-18 01:03 redj Assigned To => redj
2013-06-18 01:03 redj Note Added: 0000908
2013-06-28 22:43 redj Note Added: 0000915
2013-06-28 22:43 redj Status resolved => feedback
2013-06-28 22:43 redj Resolution fixed => reopened
2013-07-06 06:32 redj Relationship added related to 0000332
2013-07-08 20:27 jerome Status feedback => assigned
2013-07-08 20:27 jerome Target Version 0.44.50 Debug => 0.44.10 64
2013-08-07 02:33 jerome Fixed in Version 0.44.10 64 => 0.44.08
2013-08-07 02:33 jerome Target Version 0.44.10 64 => 0.44.08
2013-08-08 20:04 redj Status assigned => resolved
2013-08-08 20:04 redj Resolution reopened => fixed
2013-08-08 20:04 redj Note Added: 0000983
2013-08-09 10:53 jerome Status resolved => closed
2013-08-24 09:20 jerome Relationship added related to 0000986



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker