View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000897Ecere SDKidepublic2013-05-07 15:072013-08-30 05:19
Reporterredj 
Assigned Toredj 
PriorityhighSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
Platform-crossplatformOS-OS Version-
Product Version0.44.07 
Target Version0.44.09Fixed in Version0.44.09 
Summary0000897: valgrind integration
Descriptionadd menu items

'Run with Valgrind'
'Debug with Valgrind'
Steps To Reproducevalgrind --vgdb=yes --vgdb-error=0 <target>
gdb: target remote | vgdb
Additional Informationadd toolbar buttons?
how do we support launching valgrid with different options
we'd need to be able to change these options pretty quickly
(as in not buried in global settings dialog or something)


TagsNo tags attached.
Attached Files

- Relationships
related to 0000906closedredj add runtime option to ecere's memory manager pooling 

-  Notes
(0000829)
jerome (administrator)
2013-05-07 18:43

Right-click on Valgrind toolbar button 'options' menu? :)
(0000832)
redj (administrator)
2013-05-07 18:52

drop down arrow beside toolbar button which drops an options panel?
adjust options, enter or click 'run' button
(0000846)
redj (administrator)
2013-05-21 19:50

ok, so I've got a "working" valgrind integration now

though it has the following issues:

1. breaking a running target is broken, must be simple fix
2. if memory pooling is not disabled in the libecere used by the target, the ide enters a _perhaps_ infinite loop of 100% cpu usage.
3. ide seems very sluggish when debugging using valgrind
(0001004)
redj (administrator)
2013-08-25 03:39

1 - that seems to be fixed in 0.44.08 or earlier
2 - don't think I'm encountering this anymore
3 - performance could maybe be improved.. hard to tell on this very fast machine
    and running with valgrind must have a performance toll...
    my question: are all the pipes/threads/semaphores/etc as fast as they can be
(0001005)
redj (administrator)
2013-08-25 03:40

issue not previously noted:
target breaks in _start when using valgrind
(0001006)
redj (administrator)
2013-08-25 03:41

fixed last issue by https://github.com/redj/ecere-sdk/commit/97fecf6737e267a02b0738ca172ec5a063cf67c2 [^]

file another issue when further improvements are required.
(0001007)
jerome (administrator)
2013-08-25 04:29

Before we can close this, since this issue mentioned options:

Could we add the missing redzone configuration option?
We already have the leak check option, right?
--redzone-size=<number>
I've also found this one useful: --track-origins=<yes|no> [default: no]

And this might come in handy for debugging leaks with Valgrind:
--leak-check=<no|summary|yes|full> [default: summary]

etc.

http://valgrind.org/docs/manual/manual-core.html#manual-core.options [^]
http://valgrind.org/docs/manual/mc-manual.html#mc-manual.options [^]
(0001029)
redj (administrator)
2013-08-29 00:09

https://github.com/redj/ecere-sdk/commit/32b502123c2d2815e35e2895a7b39c650d288f6f [^]
(0001034)
jerome (administrator)
2013-08-29 09:01

Could you please add 'Default' to the red zone size (not passing any option) and make that the default?
(0001039)
redj (administrator)
2013-08-29 19:01

https://github.com/redj/ecere-sdk/commit/f208d2c60c3bf3b2042eefeb9703a30fa39c5d2c [^]
(0001044)
jerome (administrator)
2013-08-30 04:36

leak check, redzone size and track origin:

https://github.com/ecere/ecere-sdk/commit/c162b9ddb46e1f96074a6450bdc4c3c6041eecc6 [^]

added a default option to redzone size option:

https://github.com/ecere/ecere-sdk/commit/5093862d259863f03127b6d21a54279c9f7cbeaf [^]

Fixed menu state reloading from workspace:

https://github.com/ecere/ecere-sdk/commit/084c0b7b5970773d29d1d30a4cb426b8c715b88d [^]

Still need to write/load to/from workspace (Redj is waiting for JSON version).

- Issue History
Date Modified Username Field Change
2013-05-07 15:07 redj New Issue
2013-05-07 18:43 jerome Note Added: 0000829
2013-05-07 18:52 redj Note Added: 0000832
2013-05-21 19:50 redj Note Added: 0000846
2013-05-23 00:04 redj Status new => assigned
2013-05-23 00:04 redj Assigned To => redj
2013-05-27 18:19 jerome Target Version 0.44.05 => 0.44.5 Debug
2013-05-27 18:19 jerome Additional Information Updated
2013-08-25 03:39 redj Note Added: 0001004
2013-08-25 03:40 redj Note Added: 0001005
2013-08-25 03:41 redj Note Added: 0001006
2013-08-25 03:41 redj Status assigned => resolved
2013-08-25 03:41 redj Fixed in Version => 0.44.09
2013-08-25 03:41 redj Resolution open => fixed
2013-08-25 04:29 jerome Note Added: 0001007
2013-08-25 04:29 jerome Target Version 0.44.50 Debug => 0.44.09
2013-08-28 18:07 jerome Status resolved => assigned
2013-08-29 00:09 redj Status assigned => resolved
2013-08-29 00:09 redj Note Added: 0001029
2013-08-29 09:01 jerome Note Added: 0001034
2013-08-29 09:01 jerome Status resolved => assigned
2013-08-29 19:01 redj Status assigned => resolved
2013-08-29 19:01 redj Note Added: 0001039
2013-08-30 04:36 jerome Note Added: 0001044
2013-08-30 04:36 jerome Status resolved => closed
2013-08-30 05:19 jerome Relationship added related to 0000906



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker