View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000757Ecere SDKidepublic2012-07-12 03:422013-08-28 17:26
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44 Ryoan-ji 
Target Version0.44.09Fixed in Version0.44.09 
Summary0000757: Modalness of reload dialog boxes is broken
Description- On Windows:
If activating the IDE whose dialog popped up by clicking on the IDE's window, it is still possible to access the menus until we click on the actual message box.
This also happens when alt-tabbing to the IDE while the message box is already up.

- On Linux:
I remember not being able to give focus back to the IDE after the reload dialog comes up, or only with a great amount of trouble.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000511closedredj Reloading of modified 'added' (e.g. shared libraries dependencies) projects & Hangs on reloading projects 

-  Notes
(0000619)
jerome (administrator)
2012-07-12 21:51

At least on Windows, this seems to have been resolved by disabling file monitors reentrancy:

https://github.com/ecere/sdk/commit/de11d23d5f9f62b1228dbb55f2b019fc383f6740 [^]
(0000893)
jerome (administrator)
2013-06-11 01:12

Awaiting feedback from Redj to verify this is still an issue on Linux and detail the problems.
(0000904)
redj (administrator)
2013-06-17 21:43

tried and failed to reproduce this with a touch to .ec/.epj
the little window is very modal!
it shows alone over whatever else is on the screen without activating it's parent ide but once you click / alt-tab to the ide in question, no menu acces or access of any sort to the parent (the ide) windows...
even when another modal window (project settings) already present
no issues of being able to click or type into the ide or any other dialog
(0000907)
jerome (administrator)
2013-06-18 00:23

Let's test this thoroughly on:
- Cinnamon
- Unity
- GNOME
- KDE

And et's try to touch multiple files (.epj, added .epj, .ec files) and clicking off and on the various windows
(0000913)
redj (administrator)
2013-06-21 15:08
edited on: 2013-06-21 15:10

cinnamon, unity, gnome, kde
.epj, .ec
multiple windows
clicking, menus, code editor
minimizing ide while modal is popped up
clicking everything again
keybord... shortcut keys..

unable to reproduce anything that *really* shouldn't happen or any blocking issue
only thing that happens is in some DE the modal dialogs like findinfiles and globalsettings will disappear behind the main ide window but those occurancees seem to exclude messagebox.

(0000914)
redj (administrator)
2013-06-21 15:49
edited on: 2013-06-21 15:53

in unity
I just got something where I can't access the ide's menus even if it's in focus
the rest works fine but can't access the menus (mouse / keyboard)
this is not exactly related to the modalness of the reload dialogs
and am unable to reproduce

(0001014)
redj (administrator)
2013-08-28 15:54
edited on: 2013-08-28 15:56

https://github.com/ecere/ecere-sdk/commit/ed3d0707210f032d4fd7a98c9d8631c6e05c81ca [^]


- Issue History
Date Modified Username Field Change
2012-07-12 03:42 jerome New Issue
2012-07-12 03:42 jerome Status new => assigned
2012-07-12 03:42 jerome Assigned To => jerome
2012-07-12 03:42 jerome Relationship added related to 0000511
2012-07-12 21:51 jerome Status assigned => resolved
2012-07-12 21:51 jerome Fixed in Version => 0.44.1 Android
2012-07-12 21:51 jerome Resolution open => fixed
2012-07-12 21:51 jerome Note Added: 0000619
2013-06-11 01:12 jerome Assigned To jerome => redj
2013-06-11 01:12 jerome Status resolved => feedback
2013-06-11 01:12 jerome Resolution fixed => reopened
2013-06-11 01:12 jerome Note Added: 0000893
2013-06-17 21:43 redj Note Added: 0000904
2013-06-18 00:23 jerome Note Added: 0000907
2013-06-21 15:08 redj Note Added: 0000913
2013-06-21 15:10 redj Note Edited: 0000913
2013-06-21 15:49 redj Note Added: 0000914
2013-06-21 15:53 redj Note Edited: 0000914
2013-08-23 22:01 jerome Status feedback => assigned
2013-08-23 22:01 jerome Fixed in Version 0.44.10 64 => 0.44.09
2013-08-23 22:01 jerome Target Version 0.44.10 64 => 0.44.09
2013-08-28 15:54 redj Status assigned => resolved
2013-08-28 15:54 redj Resolution reopened => fixed
2013-08-28 15:54 redj Note Added: 0001014
2013-08-28 15:56 redj Note Edited: 0001014
2013-08-28 17:26 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker