View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000736Ecere SDKidepublic2012-04-04 22:262013-08-07 03:33
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeverityblockReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44 Ryoan-ji 
Target Version0.44.08Fixed in Version0.44.08 
Summary0000736: Quick Project broken?
DescriptionI've tried to use the Quick project feature a couple time, and the IDE locks up forever when you press the OK button of the Quick project dialog?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000583)
redj (administrator)
2012-04-05 15:47
edited on: 2012-04-05 15:48

trying to test on linux I get a crash

  0 inside ??, /lib32/libc.so.6
  1 inside _IO_file_xsputn, /lib32/libc.so.6
  2 inside fwrite, /lib32/libc.so.6
  3 __ecereNameSpace__ecere__sys__File_Write Method, src/sys/File.ec:474
  4 __ecereNameSpace__ecere__sys__File_WriteData Method, src/sys/File.ec:224
  5 __ecereNameSpace__ecere__com__Iterator_Next Method, src/com/containers/Container.ec:51
  6 __ecereNameSpace__ecere__sys__WriteArray Function, src/sys/JSON.ec:575
  7 __ecereNameSpace__ecere__sys__WriteValue Function, src/sys/JSON.ec:735
  8 __ecereNameSpace__ecere__sys___WriteJSONObject Function, src/sys/JSON.ec:913
  9 __ecereNameSpace__ecere__sys__WriteJSONObject Function, src/sys/JSON.ec:753
 10 Project_Save Method, src/project/Project.ec:951
 11 __ecereInstMeth___ecereNameSpace__ecere__gui__controls__Button_NotifyClicked__00000002 Function, src/dialogs/NewProjectDialog.ec:442
 12 __ecereNameSpace__ecere__gui__controls__Button_OnLeftButtonUp Method, src/gui/controls/Button.ec:574
 13 __ecereNameSpace__ecere__gui__Window_MouseMessage Method, src/gui/Window.ec:4236
 14 __ecereNameSpace__ecere__gui__drivers__XInterface_ProcessInput Method, src/gui/drivers/XInterface.ec:1439
 15 __ecereNameSpace__ecere__gui__GuiApplication_ProcessInput Method, src/gui/GuiApplication.ec:768
 16 __ecereNameSpace__ecere__gui__Window_DoModal Method, src/gui/Window.ec:7060
 17 __ecereNameSpace__ecere__gui__Window_Modal Method, src/gui/Window.ec:6418
 18 __ecereInstMeth___ecereNameSpace__ecere__gui__controls__MenuItem_NotifySelect__00000027 Function, src/ide.ec:812
 19 __ecereNameSpace__ecere__gui__controls__PopupMenu_MenuItemSelection Method, src/gui/controls/Menu.ec:891
 20 __ecereNameSpace__ecere__gui__controls__PopupMenu_OnLeftButtonUp Method, src/gui/controls/Menu.ec:1853
 21 __ecereNameSpace__ecere__gui__Window_MouseMessage Method, src/gui/Window.ec:4236
 22 __ecereNameSpace__ecere__gui__drivers__XInterface_ProcessInput Method, src/gui/drivers/XInterface.ec:1439
 23 __ecereNameSpace__ecere__gui__GuiApplication_ProcessInput Method, src/gui/GuiApplication.ec:768
 24 __ecereNameSpace__ecere__gui__GuiApplication_Main Method, src/gui/GuiApplication.ec:684
 25 main Function, obj/debug.linux/ide.main.ec:3968

not sure if this was tested at all on linux :P
the buffer is null but the stack is weird :S

(0000610)
jerome (administrator)
2012-07-11 19:39

There was memory corruption caused by the property freeing the configurations being assigned.

Fixed by https://github.com/ecere/sdk/commit/b3e3d25958755a6a323958eb9b312607e15272d6 [^]

- Issue History
Date Modified Username Field Change
2012-04-04 22:26 jerome New Issue
2012-04-05 15:47 redj Note Added: 0000583
2012-04-05 15:48 redj Note Edited: 0000583
2012-07-11 19:39 jerome Status new => resolved
2012-07-11 19:39 jerome Fixed in Version => 0.44.1 Android
2012-07-11 19:39 jerome Resolution open => fixed
2012-07-11 19:39 jerome Assigned To => jerome
2012-07-11 19:39 jerome Note Added: 0000610
2013-05-22 20:29 jerome Status resolved => closed
2013-08-07 03:33 jerome Fixed in Version 0.44.10 64 => 0.44.08
2013-08-07 03:33 jerome Target Version 0.44.10 64 => 0.44.08



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker