View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000696Ecere SDKidepublic2012-03-23 17:092013-08-07 03:33
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.08Fixed in Version0.44.08 
Summary0000696: Hitting Project/Clean while debugging app puts the debugger in an unusable state
DescriptionThe project will be terminated
Files get deleted,
but all debug menu items will be disabled
Steps To ReproduceOpen a project, F5, Go back to the IDE without closing the aplication, hit Clean
TagsNo tags attached.
Attached Files

- Relationships
related to 0000694closed Run app in IDE creates exe and does not exit from it 

-  Notes
(0000547)
redj (administrator)
2012-03-27 21:04
edited on: 2012-04-05 15:08

https://github.com/ecere/sdk/commit/af7f71cba9148fa03d3e2e251128c445aadd2f43 [^]

(0000892)
jerome (administrator)
2013-06-11 00:39

There was a strange issue I ran into where doing a clean while debugging the app would bring up the confirmation dialog, and then saying 'yes' would not actually do the clean.

At that time, I believe the 'ide.debugger.prjConfig == config' comparison inside DebugStopForMake() seemed to fail, and thus DebugStop() would not get called.

Despite a lot of effort to reproduce by both me and Redj, we were unable to reproduce the issue, and looking back it looks quite strange because for the dialog to show up in the first place, prj.GetConfigIsInDebugSession(config) would have already verified that check to be true.

Assuming the problem was caused by having missed a required rebuild, and closing the issue. Reopen if it ever resurfaces again.

- Issue History
Date Modified Username Field Change
2012-03-23 17:09 jerome New Issue
2012-03-23 17:13 jerome Relationship added related to 0000694
2012-03-27 21:03 redj Status new => assigned
2012-03-27 21:03 redj Assigned To => redj
2012-03-27 21:04 redj Status assigned => resolved
2012-03-27 21:04 redj Resolution open => fixed
2012-03-27 21:04 redj Note Added: 0000547
2012-03-27 21:04 redj Fixed in Version => 0.44.1 Android
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2012-04-05 15:08 redj Note Edited: 0000547
2013-06-11 00:39 jerome Status resolved => closed
2013-06-11 00:39 jerome Note Added: 0000892
2013-08-07 03:33 jerome Fixed in Version 0.44.10 64 => 0.44.08
2013-08-07 03:33 jerome Target Version 0.44.10 64 => 0.44.08



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker