View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000685Ecere SDKcompilerpublic2012-02-26 14:282014-08-08 18:17
Reporterredj 
Assigned Tojerome 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformCross-PlatformOS\o/OS Version;-)
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000685: compiler/ecc: generated c code does not compile clean yet
Descriptionin the ide we have to hide warnings
// Don't show GCC warnings about generated C code because it does not compile clean yet...
TagsNo tags attached.
Attached Files

- Relationships
related to 0000241closedjerome No "Function shouldn't return a value" warnings 
related to 0000018closedjerome Better parsing in IDE project building to prevent errors from parallel builds (-jX) 

-  Notes
(0001315)
jerome (administrator)
2014-05-23 11:01

Let's just filter warnings caused by the generated C code and let the informative warnings through for now.

We'll improve on some of the generated C code (e.g. declared inside parameter list) with the topographic sort, and ultimately we might generate LLVM byte code instead of C.
(0001349)
jerome (administrator)
2014-07-01 07:49

Most generated C code warnings are now taken care of with the topo sort and other improvements.

TopoSort implemented by:
https://github.com/ecere/ecere-sdk/commit/5165f9a12208bc4742da1914e53cb7ffe40199c2 [^]

Just a few warnings to take care of remain...
(0001355)
jerome (administrator)
2014-07-06 12:17

As of:

https://github.com/ecere/ecere-sdk/commit/e4f9c9ccea3da81c722f20dff7452503aec226a9 [^]

All generated code compiles clean.

- Issue History
Date Modified Username Field Change
2012-02-26 14:28 redj New Issue
2012-03-08 16:51 redj Target Version => 0.45 Ginkakuji
2012-03-29 07:50 redj Category => eC Compiling Tools
2012-03-29 07:50 redj Project @2@ => Ecere SDK
2014-05-23 10:59 jerome Status new => assigned
2014-05-23 10:59 jerome Assigned To => jerome
2014-05-23 10:59 jerome Relationship added related to 0000241
2014-05-23 11:01 jerome Note Added: 0001315
2014-05-23 11:01 jerome Target Version 0.45 Ginkakuji => 0.44.10 64
2014-06-10 06:43 jerome Relationship added related to 0000018
2014-07-01 07:49 jerome Note Added: 0001349
2014-07-06 12:17 jerome Note Added: 0001355
2014-07-06 12:17 jerome Status assigned => resolved
2014-07-06 12:17 jerome Fixed in Version => 0.44.10 64
2014-07-06 12:17 jerome Resolution open => fixed
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker