View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000677Ecere SDKidepublic2012-02-05 08:262013-08-07 03:33
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.08Fixed in Version0.44.08 
Summary0000677: Support a way to disable -ffast-math per file
DescriptionThis is required to generate makefiles to build the SQLite driver
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000636)
redj (administrator)
2012-10-22 00:29

please describe "a way"
(0000637)
jerome (administrator)
2012-10-22 04:33

We need a per file X config X platform setting (probably a bool checkbox "Fast Math") in the Project Settings near the Optimization drop box, along with new member in ProjectOptions class (which should automatically make it into the .epj format) and the matching Makefile/generation code to pass -ffast-math or not to GCC.
(0000638)
redj (administrator)
2012-10-22 07:53

and right now -ffast-math is default for .ec files when optimising for speed, right?

how is this default going to be reflected in the gui?

enabling "Fast Math" when Optimization is set to for speed?
as well as enabling "Fast Math" in the release config of a new project?
(0000639)
jerome (administrator)
2012-10-22 08:04

By default, the release config will have both optimization set to speed and fast-math on.

Changing optimization or fast math will remain independent.
(0000640)
jerome (administrator)
2012-10-22 08:10

Note: Options in existing projects which don't have fast-math set but have optimization set to Speed should probably auto-turn fast-math on.
(0000644)
redj (administrator)
2012-10-24 10:42

regarding that last note:
how can we do that?
the new fastMatch option not being set (100% abscent from the epj file) doesn't mean the epj file is old and should be converted and thus set fastMath to true if optimize is set to speed... it could just as well mean the new fastMath option is intentionally left unset in this ProjectOptions instance...
(0000645)
redj (administrator)
2012-10-24 10:46
edited on: 2012-10-25 16:11

https://github.com/ecere/sdk/commit/cca0a0e2600cf87d9a1667dd9a7bcc50a46e058b [^]

note: the new fastMath option is not working on a per-file basis just like optimize isn't either...

(0000646)
jerome (administrator)
2012-10-24 17:36

Both of those options should work on a per-file basis.
(0000652)
redj (administrator)
2012-10-30 15:50
edited on: 2013-05-05 16:11

lost link because of amended commit (029b8935776edda6bfc6896328a26c93b96a13b7)

assuming this is the correct commit:
https://github.com/ecere/sdk/commit/97becb000ea3983ce112aab0fd33b223e91f4887 [^]


- Issue History
Date Modified Username Field Change
2012-02-05 08:26 jerome New Issue
2012-03-08 16:01 redj Target Version old 0.44.pre3 => 0.45 Ginkakuji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2012-08-10 14:19 jerome Priority urgent => immediate
2012-08-10 14:19 jerome Target Version 0.45 Ginkakuji => 0.44.1 Android
2012-10-22 00:29 redj Note Added: 0000636
2012-10-22 00:29 redj Status new => feedback
2012-10-22 04:33 jerome Note Added: 0000637
2012-10-22 04:33 jerome Assigned To => redj
2012-10-22 04:33 jerome Status feedback => assigned
2012-10-22 07:53 redj Note Added: 0000638
2012-10-22 08:04 jerome Note Added: 0000639
2012-10-22 08:10 jerome Note Added: 0000640
2012-10-24 10:42 redj Note Added: 0000644
2012-10-24 10:46 redj Status assigned => resolved
2012-10-24 10:46 redj Fixed in Version => 0.44.1 Android
2012-10-24 10:46 redj Resolution open => fixed
2012-10-24 10:46 redj Note Added: 0000645
2012-10-24 10:47 redj Note Edited: 0000645
2012-10-24 17:36 jerome Note Added: 0000646
2012-10-24 17:36 jerome Status resolved => assigned
2012-10-25 16:11 redj Note Edited: 0000645
2012-10-30 15:50 redj Status assigned => resolved
2012-10-30 15:50 redj Note Added: 0000652
2013-05-05 16:06 redj Note Edited: 0000652
2013-05-05 16:11 redj Note Edited: 0000652
2013-05-22 20:31 jerome Status resolved => closed
2013-08-07 03:33 jerome Fixed in Version 0.44.10 64 => 0.44.08
2013-08-07 03:33 jerome Target Version 0.44.10 64 => 0.44.08



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker