View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000648Ecere SDKecerepublic2011-09-30 21:132014-08-08 18:18
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000648: What kind of alpha blending are we doing right now in GDI?
DescriptionWhy does Ollie has this black shadow behind him on a white background?
See attached image.
Aren't we using PNG alpha blending on all icons and they work fine?
TagsNo tags attached.
Attached Filespng file icon ollie2.png [^] (34,046 bytes) 2011-09-30 21:13

- Relationships
related to 0000284closedjerome opacity goes from 75% (in the PNG) to 100% (backed by 'white') 

-  Notes
(0001299)
jerome (administrator)
2014-05-20 19:33

We are doing alpha blending in the LFB driver.
This issue seems to be gone, possibly was only missing the alphaBlended flag to be set on the IDE's PictureEdit:

Fixed by:
https://github.com/ecere/ecere-sdk/commit/94132fa31ea61e063de6f1a44ea4b053510f444a [^]
This helped some PNGs as well:
https://github.com/ecere/ecere-sdk/commit/61f70093a82be11336467c6e3f177f1c911fa50d [^]

- Issue History
Date Modified Username Field Change
2011-09-30 21:13 jerome New Issue
2011-09-30 21:13 jerome File Added: ollie2.png
2011-10-01 04:31 jerome Relationship added related to 0000284
2012-03-08 15:44 redj Target Version old 0.44.pre2 => 0.45 Ginkakuji
2012-03-29 07:53 redj Category => Ecere Runtime Library
2012-03-29 07:53 redj Project @1@ => Ecere SDK
2013-04-26 18:28 jerome Target Version 0.45 Ginkakuji => 0.44.8 Silver
2014-05-20 06:42 jerome Assigned To => jerome
2014-05-20 06:42 jerome Status new => assigned
2014-05-20 06:42 jerome Target Version 0.44.80 Silver => 0.44.10 64
2014-05-20 19:33 jerome Status assigned => resolved
2014-05-20 19:33 jerome Fixed in Version => 0.44.10 64
2014-05-20 19:33 jerome Resolution open => fixed
2014-05-20 19:33 jerome Note Added: 0001299
2014-08-08 18:18 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker