View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000598Ecere SDKcompilerpublic2011-06-13 17:372014-08-08 18:17
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000598: No warning on "case pageUp: pageDown:"
DescriptionNeed one.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001331)
jerome (administrator)
2014-06-10 06:49

Fixed by:
https://github.com/ecere/ecere-sdk/commit/c584e08c1e4973b565444da986bc79c213fe5c73 [^]
(0001332)
jerome (administrator)
2014-06-10 07:16
edited on: 2014-06-10 07:20

Reverting decision to issue a warning, as it is correct C, and GCC already issues a warning regarding an unused label which will serve the intended purpose.

https://github.com/ecere/ecere-sdk/commit/dcb7b6d4bced526f06850834e642d86e9aae47c9 [^]


- Issue History
Date Modified Username Field Change
2011-06-13 17:37 jerome New Issue
2012-03-08 15:43 redj Target Version old 0.44.pre2 => 0.45 Ginkakuji
2012-03-29 07:50 redj Category => eC Compiling Tools
2012-03-29 07:50 redj Project @2@ => Ecere SDK
2013-09-10 19:14 jerome Target Version 0.45 Ginkakuji => 0.46 eC II
2014-05-21 19:42 jerome Summary No syntax error on "case pageUp: pageDown:" => No warning on "case pageUp: pageDown:"
2014-06-10 06:40 jerome Status new => assigned
2014-06-10 06:40 jerome Assigned To => jerome
2014-06-10 06:40 jerome Priority urgent => immediate
2014-06-10 06:40 jerome Target Version 0.46 eC II => 0.44.10 64
2014-06-10 06:49 jerome Status assigned => resolved
2014-06-10 06:49 jerome Fixed in Version => 0.44.10 64
2014-06-10 06:49 jerome Resolution open => fixed
2014-06-10 06:49 jerome Note Added: 0001331
2014-06-10 07:16 jerome Note Added: 0001332
2014-06-10 07:20 jerome Note Edited: 0001332
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker