View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000564Ecere SDKide:buildsystempublic2010-10-29 05:012013-08-07 03:33
Reporterredj 
Assigned Toredj 
PriorityimmediateSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformCross-PlatformOS\o/OS Version;-)
Product Version 
Target Version0.44.08Fixed in Version0.44.08 
Summary0000564: implement a way to specify custom compiler flags [ compiler and project level ]
DescriptionWe don't have any way of specifying custom compile flags ... blatantly missing

We need this at both the Compiler and Project level

(We got linker flags at both levels already)
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0000794closedredj allow specifying custom compiler / linker flags 

-  Notes
(0000753)
redj (administrator)
2013-04-27 02:38
edited on: 2013-05-05 15:58

implemented by https://github.com/ecere/sdk/commit/17f56fbd090b5cbd1fb46e300a397f9932440454 [^]

(0000853)
jerome (administrator)
2013-05-27 18:11

There are a couple of issues with this new functionality.

1. The project level option seems to save properly, but does not show up anywhere in the makefile.
2. The compiler level option seems to work, but it looks like it adds an extra hyphen. I'd expect the user to enter whatever - as part of the option entry, e.g. -fno-strict-aliasing or --sysroot=dir .
(0000857)
redj (administrator)
2013-05-28 20:31

fixed by https://github.com/redj/ecere-sdk/commit/198f9ef204a51069954f2d1e1f6055a09d7f99f6 [^]

- Issue History
Date Modified Username Field Change
2010-10-29 05:01 redj New Issue
2010-10-29 05:01 redj Status new => assigned
2010-10-29 05:01 redj Assigned To => redj
2012-03-08 15:41 redj Target Version old 0.44.pre2 => 0.45 Ginkakuji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2012-03-29 08:42 redj Category ide => ide:buildsystem
2012-03-29 08:42 redj Summary ide / build system: implement a way to specify compiler options (compile flags) => implement a way to specify compiler options (compile flags)
2013-04-24 05:34 jerome Target Version 0.45 Ginkakuji => 0.44.1 64
2013-04-24 20:29 jerome Note Added: 0000722
2013-04-24 20:29 jerome Note Edited: 0000722
2013-04-24 20:29 jerome Note Deleted: 0000722
2013-04-24 20:30 jerome Description Updated
2013-04-24 20:30 jerome Summary implement a way to specify compiler options (compile flags) => implement a way to specify compiler options (compiler and linker flags) [ compiler and project level ]
2013-04-25 09:01 jerome Summary implement a way to specify compiler options (compiler and linker flags) [ compiler and project level ] => implement a way to specify custom compiler flags [ compiler and project level ]
2013-04-25 09:01 jerome Description Updated
2013-04-27 02:38 redj Status assigned => resolved
2013-04-27 02:38 redj Fixed in Version => 0.44.1 64
2013-04-27 02:38 redj Resolution open => fixed
2013-04-27 02:38 redj Note Added: 0000753
2013-04-27 05:47 redj Note Edited: 0000753
2013-05-05 15:58 redj Note Edited: 0000753
2013-05-07 05:00 jerome Relationship added has duplicate 0000794
2013-05-27 18:11 jerome Note Added: 0000853
2013-05-27 18:11 jerome Status resolved => assigned
2013-05-28 20:31 redj Status assigned => resolved
2013-05-28 20:31 redj Note Added: 0000857
2013-06-11 01:03 jerome Status resolved => closed
2013-08-07 03:33 jerome Fixed in Version 0.44.10 64 => 0.44.08
2013-08-07 03:33 jerome Target Version 0.44.10 64 => 0.44.08



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker