View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000541Ecere SDKidepublic2010-08-11 06:032013-05-19 22:15
ReporterD_Bane 
Assigned Tojerome 
PriorityimmediateSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000541: not allowed to replace immediately.
DescriptionIf you select some text in IDE and press Ctrl+R it will open replace dialog with that word as what to replace. The problem is that it doesn't enable buttons unless you change that EditBox too (the first on "Find what:"), even though it's all entered. Should check if there is text on load.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000332)
jerome (administrator)
2010-08-14 20:47

The 'find what' is the problem here.
It's the only thing that decides whether the buttons are enabled or not.
If text is selected, it goes into 'find what' but the button is not enabled.
Even if you put text in 'Replace with', it still won't enable the button.
But the next time you bring up the dialog, it will be enabled (because there was already text in 'Find what')
(0000334)
jerome (administrator)
2010-08-15 15:27

Added revision 17 to E:\root\sdk\ecere\src\gui\dialogs\ReplaceDialog.ec

- Issue History
Date Modified Username Field Change
2010-08-11 06:03 D_Bane New Issue
2010-08-14 20:47 jerome Note Added: 0000332
2010-08-14 20:48 jerome Assigned To => redj
2010-08-14 20:48 jerome Priority normal => immediate
2010-08-14 20:48 jerome Status new => assigned
2010-08-14 20:48 jerome Fixed in Version => 0.44 pre-release 2
2010-08-14 20:48 jerome Status assigned => confirmed
2010-08-15 15:16 jerome Status confirmed => assigned
2010-08-15 15:16 jerome Assigned To redj => jerome
2010-08-15 15:27 jerome Status assigned => resolved
2010-08-15 15:27 jerome Resolution open => fixed
2010-08-15 15:27 jerome Note Added: 0000334
2012-03-08 15:33 redj Target Version => 0.44 Ryoan-ji
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker