View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000517Ecere SDKidepublic2010-07-28 18:092013-05-19 22:15
Reporterjerome 
Assigned Tothexa4 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000517: Auto Indenting Quirks
Description(This is all from a perspective of using the free caret option in the IDE)

- Hitting enter in between two curly brackets sometimes tabs the closing bracket...
e.g.:

class Bla { *hitting enter here* }

This seems to depend on whether you leave spaces before the bracket or not..

{} type enter between the brackets here and it gets tab
{ } type enter right before the bracket and it's fine
{ } type enter before the space and the bracket gets tabbed...

If you tab the bracket after it's on its own line with spaces between, it stays tabbed.

- Let's have an option to disable auto indenting and/or to make it work like it used to in previous versions
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000296)
jerome (administrator)
2010-07-30 11:51

I ran across some more quirks...

Consider the following code:

int bla()

{

   int a = 4;

   if(a == 4)

   {

      printf("");


   ^ type } here and it goes to the first column.

Then I'm going to position my caret right under the 'i' or the if (or the opening bracket) on the following line and type the closing bracket '}'.
It brings my caret back by 3 spaces, although I'm already positioned properly. Looks like the code is not taking in consideration the current horizontal position of the caret when applying the logic!
(0000363)
thexa4 (developer)
2010-09-04 21:30

Added revision 95 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec

The } now gets the same indentation as the starting {

{,Enter now only indents a tab if there is no } next to it.
(0000366)
thexa4 (developer)
2010-09-04 23:22

Auto indenting doesn't work yet.
(0000367)
thexa4 (developer)
2010-09-04 23:31

Added revision 97 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec
(0000368)
thexa4 (developer)
2010-09-04 23:57

Added revision 98 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec

Added support for adding tabs
(0000382)
jerome (administrator)
2010-09-25 19:15

There is a remaining quirk. Type the following, notice how the last closing bracket goes under the set's bracket (I was using FreeCaret mode, if it has anything to do with it.)

class Bla {
   property int cool {
      set
      {
         {
            {
            }
      }
(0000383)
thexa4 (developer)
2010-09-25 21:14

Added revision 99 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec
(0000384)
jerome (administrator)
2010-09-26 02:05
edited on: 2010-09-26 02:10

Minor revision:

Added revision 100 to E:\newroot\sdk\ecere\src\gui\controls\EditBox.ec

Used EditLine::count instead of strlen, and reverted to the use of EditLine's 'buffer' data member instead of the 'text' property.


- Issue History
Date Modified Username Field Change
2010-07-28 18:09 jerome New Issue
2010-07-28 18:10 jerome Relationship added child of 0000429
2010-07-29 01:46 thexa4 Status new => assigned
2010-07-29 01:46 thexa4 Assigned To => thexa4
2010-07-30 11:51 jerome Note Added: 0000296
2010-09-04 21:30 thexa4 Note Added: 0000363
2010-09-04 21:31 thexa4 Status assigned => resolved
2010-09-04 21:31 thexa4 Fixed in Version => 0.44 pre-release 2
2010-09-04 21:31 thexa4 Resolution open => fixed
2010-09-04 23:22 thexa4 Note Added: 0000366
2010-09-04 23:22 thexa4 Status resolved => assigned
2010-09-04 23:31 thexa4 Status assigned => resolved
2010-09-04 23:31 thexa4 Note Added: 0000367
2010-09-04 23:57 thexa4 Note Added: 0000368
2010-09-25 19:15 jerome Note Added: 0000382
2010-09-25 19:15 jerome Status resolved => assigned
2010-09-25 21:14 thexa4 Note Added: 0000383
2010-09-25 21:14 thexa4 Status assigned => resolved
2010-09-26 02:05 jerome Note Added: 0000384
2010-09-26 02:10 jerome Note Edited: 0000384
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:42 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker