View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000516Ecere SDKidepublic2010-07-28 15:562013-05-19 22:15
Reporterjerome 
Assigned Tothexa4 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000516: Scrolling Issues related to Line Numbers
DescriptionWhen scrolling the text vertically using Ctrl-Up / Ctrl-Down, the new lines coming into view don't get any line numbers coming up, plus the line numbers for 2 lines around the cursor are blanked out. moving the cursor down or up by one line makes all the lines come back up.

This suggests that extra updates are done when just moving the cursor around, only the portion that changed should need to be updated.

Additionally, moving the cursor to the right on code that goes past the visible area does not make the code page scroll soon enough. It might be that the editbox spans past the now smaller area of the CodeEditor for displaying code (The line numbers margin taking up more space than before).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000281)
jerome (administrator)
2010-07-28 15:59

Scrolling with the thumb also makes the line numbers dissappear.
(0000282)
thexa4 (developer)
2010-07-28 16:16

Redraws are done in the OnRedrawOverChildren function and should have nothing to do with moving the cursor around.

On Kubuntu 10.04 I am unable to reproduce the disappearing of the line numbers.
The horizontal scrolling issue is fixed.
(0000283)
jerome (administrator)
2010-07-28 16:22

This likely has to do with the 'Surface::Scroll' method that is used, which makes performance faster on Windows. It uses ScrollDC to scroll the contents of the DC. On Linux there is no scrolling support and thus the issue probably does not happen on Linux.

The cursor moving around generates some 'Update' calls.

The issue here is likely about which extents Window::Update() is called with.

You can reassign the issue to Redj if you wish if you have no way of testing this on Windows.
(0000406)
jerome (administrator)
2010-12-04 21:28

Added revision 103 to E:\newroot\sdk\ecere\src\gui\controls\EditBox.ec
Added revision 161 to E:\newroot\sdk\ide\src\ide.ec
Added revision 147 to E:\newroot\sdk\ide\src\designer\CodeEditor.ec

The Line Numbers have been moved to the CodeEditor, with the rest of the margin stuff (breakpoints/stack frames/etc.).

Those issues should all be things of the past.

- Issue History
Date Modified Username Field Change
2010-07-28 15:56 jerome New Issue
2010-07-28 15:56 jerome Relationship added child of 0000429
2010-07-28 15:56 jerome Status new => assigned
2010-07-28 15:56 jerome Assigned To => thexa4
2010-07-28 15:59 jerome Note Added: 0000281
2010-07-28 16:16 thexa4 Note Added: 0000282
2010-07-28 16:22 jerome Note Added: 0000283
2010-07-28 18:02 thexa4 Assigned To thexa4 => redj
2010-08-07 17:54 jerome Assigned To redj => thexa4
2010-12-04 21:28 jerome Note Added: 0000406
2010-12-04 21:29 jerome Status assigned => resolved
2010-12-04 21:29 jerome Fixed in Version => 0.44 pre-release 2
2010-12-04 21:29 jerome Resolution open => fixed
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:42 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker