View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000453Ecere SDKidepublic2010-07-26 02:502013-05-19 22:15
Reporterredj 
Assigned Toredj 
PriorityimmediateSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000453: ide: new project: updating of the path with the name and the dialog needs a few fixes
Descriptionupdating of the path with the name and the dialog needs a few fixes
New Project has some very messed up behavior! It changed the path I had set for the project directory to something totally different... different parent dir...
TagsNo tags attached.
Attached Files

- Relationships
related to 0000449closedjerome ide: new project: project filename loses extension 
related to 0000468closedjerome ide: Path box improvements and browse object dir everywere 

-  Notes
(0000247)
jerome (administrator)
2010-07-26 02:54
edited on: 2010-08-21 15:24

- Buffer Overrun

Buffer Overrun
   Allocation Stack:
      obj/memoryGuard.win32/ide.main.ec:main
      
src/gui/GuiApplication.ec:gui__GuiApplication_Main
src/gui/GuiApplication.ec:gui__GuiApplication_ProcessInput
src/gui/drivers/Win32Interface.ec:Win32Interface_ProcessInput
src/gui/drivers/Win32Interface.ec:Win32Interface_ApplicationWindow
src/gui/drivers/Win32Interface.ec:Win32Interface_ProcessKeyMessage
src/gui/Window.ec:KeyMessage
src/gui/controls/Menu.ec:PopupMenu_OnKeyHit
src/gui/controls/Menu.ec:PopupMenu_MenuItemSelection
src/ide.ec:__ecereInstMeth___MenuItem_NotifySelect__00000005
src/gui/Window.ec:Modal
src/gui/Window.ec:DoModal
src/gui/GuiApplication.ec:GuiApplication_ProcessInput
src/gui/drivers/Win32Interface.ec:Win32Interface_ProcessInput
src/gui/drivers/Win32Interface.ec:Win32Interface_ApplicationWindow
src/gui/drivers/Win32Interface.ec:Win32Interface_ProcessKeyMessage
src/gui/Window.ec:KeyMessage
src/gui/Window.ec:KeyMessage
src/gui/Window.ec:CycleChildren
src/gui/Window.ec:ActivateEx
src/gui/Window.ec:PropagateActive
src/gui/controls/EditBox.ec:EditBox_OnActivate
../extras/PathBox.ec:__ecereInstMeth___EditBox_NotifyModified__00000001
src/dialogs/NewProjectDialog.ec:__ecereInstMeth_PathBox_NotifyModified__00000000
../extras/PathBox.ec:PathBox_Set_path
../extras/PathBox.ec:PathBox_CheckFileExists
src/sys/File.ec:FileExists

- Must be related to this problem:

Entering anything in the 'location box' in MemoryGuard discards it

(0000258)
jerome (administrator)
2010-07-26 03:39

There was quite a bit of logic that was embedded in the choice of the dir.

Notably, it checks if the dir name matches the project name.
If it does sometimes it assumes you'll want to change both.
It tries to autofill the dir name with the name of the project.
It tries to remember the 'last project directory', although that's kind of confused with the open project dialog, the save project dialog, the new project dialog, etc.

We need to clearly document an intended behavior that always makes sense, in details.
(0000345)
jerome (administrator)
2010-08-21 15:35

There is a discrepency with the behavior entering a directory in the editbox vs chosing it with the file dialog. After you modify the project location with the editbox, it 'locks' it in place i.e. modifying the ProjectName will PathCat to the end of the location, as opposed to replacing the last sub dir.

However if you chose a directory with the file dialog, and then enter a project name, it will remove the last part of the directory, which is really not what we want. We should make that work exactly like editing the editbox.

Actually, editing with the file dialog, it seems to remember the OLD name in there before selecting it with the file dialog (after editing the project name).

Let's first fix the Buffer Overruns and then look at the behavior again.
(0000346)
jerome (administrator)
2010-08-21 15:40

About the locking, perhaps that would be the proper way to do it?
Because right now it bases itself solely on whether the directory are the same or not...
So now putting a project name, hitting tab, adds the project name to the location.
Then if you shift-tab, delete the project name, the directory will stay there. (Or maybe if deleting the project name it should delete the name part in the location box if we want to keep it this way?)

Because otherwise when you go back and put another project name, it's going to add one more directory level.
(0000347)
jerome (administrator)
2010-08-21 15:42

To Summarize:

1. Fix the PathBox buffer overrun
2. Fix the problem where it remembers the path from before as opposed to the one selected with the directory selection dialog
3. Delete the project name part of the location when clearing the project name
(0000365)
redj (administrator)
2010-09-04 22:43

addressing 1.
fixed memory issue in PathBox

Added revision 10 to sdk\extras\PathBox.ec
(0000369)
redj (administrator)
2010-09-05 00:34

addressing the rest

Added revision 11 to sdk\extras\PathBox.ec
Added revision 45 to sdk\ide\src\dialogs\NewProjectDialog.ec

- Issue History
Date Modified Username Field Change
2010-07-26 02:50 redj New Issue
2010-07-26 02:50 redj Relationship added related to 0000449
2010-07-26 02:50 redj Relationship added child of 0000429
2010-07-26 02:54 jerome Note Added: 0000247
2010-07-26 03:25 redj Note Added: 0000254
2010-07-26 03:25 redj Description Updated
2010-07-26 03:39 jerome Note Added: 0000258
2010-07-26 19:34 thexa4 Fixed in Version => 0.44 draft 2
2010-08-21 15:16 jerome Note Deleted: 0000254
2010-08-21 15:24 jerome Note Edited: 0000247
2010-08-21 15:27 jerome Relationship added related to 0000468
2010-08-21 15:27 jerome Fixed in Version 0.44 pre-release 2 =>
2010-08-21 15:35 jerome Note Added: 0000345
2010-08-21 15:36 jerome Status new => assigned
2010-08-21 15:36 jerome Assigned To => redj
2010-08-21 15:40 jerome Note Added: 0000346
2010-08-21 15:42 jerome Note Added: 0000347
2010-09-04 22:43 redj Note Added: 0000365
2010-09-05 00:34 redj Status assigned => resolved
2010-09-05 00:34 redj Resolution open => fixed
2010-09-05 00:34 redj Note Added: 0000369
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:35 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker