View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000446Ecere SDKdocumentorpublic2010-07-26 02:302013-05-19 22:15
Reporterredj 
Assigned Tojerome 
PriorityimmediateSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000446: documentor: ecdoc path reliability
Descriptionmake sure the whole eCdoc path thing works well, reliably, and the way users expect.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000155closedmothdragon Temporary patch for a fixed path in Documentor 

-  Notes
(0000269)
jerome (administrator)
2010-07-26 13:17

Beware of Vista/Win 7's reluctance to write in Program Files, and its use of a shadow file in AppData/VirtualStore!

Might be the cause of some of these issues.
(0000352)
jerome (administrator)
2010-08-21 18:43

Freed memory read/write were present as a result of not making a copy of the 'contents' property retrieved from the EditBox.

This has been fixed, and except from having to be aware of the VirtualStore (which will always override what's in Program Files for both reading & writing), this issue seems to be a thing of the past.

Also moved the doc/ folder to sdk/doc as opposed to being spread out in sdk/ecere/doc/ and eda/libeda/doc, and fixed the top level Makefile install rules accordingly. This will work better to edit all the documentation in the same directory, using this setting.

Eventually the goal is to have the .eCdoc to be embedded as a resource inside each shared library (libecere.so/libEDA.so/...), and the 'User' documentation tool along with the auto complete info will pick it up from there.

- Issue History
Date Modified Username Field Change
2010-07-26 02:30 redj New Issue
2010-07-26 02:31 redj Relationship added child of 0000429
2010-07-26 02:31 redj Relationship added related to 0000155
2010-07-26 02:33 redj Relationship added related to 0000447
2010-07-26 02:33 redj Relationship deleted related to 0000447
2010-07-26 13:17 jerome Note Added: 0000269
2010-07-26 19:33 thexa4 Fixed in Version => 0.44 draft 2
2010-07-26 20:09 redj Fixed in Version 0.44 draft 2 =>
2010-07-26 20:09 redj Target Version => 0.44 draft 2
2010-08-21 18:43 jerome Note Added: 0000352
2010-08-21 18:44 jerome Status new => assigned
2010-08-21 18:44 jerome Assigned To => jerome
2010-08-21 18:44 jerome Status assigned => resolved
2010-08-21 18:44 jerome Resolution open => fixed
2012-03-08 15:31 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:35 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:43 redj Category => Documentation System
2012-03-29 07:43 redj Project @7@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker