View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000393Ecere SDKidepublic2010-02-25 15:252013-05-19 22:15
Reporterthexa4 
Assigned Tothexa4 
PriorityimmediateSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000393: Select All moves view to the end of the file
DescriptionEvery time you select everything the view moves to the end of the file.
Tagsv0.44d2
Attached Filespng file icon ide-select-all-broken.png [^] (98,232 bytes) 2010-07-25 23:30

- Relationships

-  Notes
(0000156)
thexa4 (developer)
2010-04-04 14:21

Added revision 87 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec
(0000207)
redj (administrator)
2010-07-25 19:48

my experience is that is still broken at the moment
when I do CTRL-A in an CodeEditor that has more lines than are shown, only the lines that are shown on the screen are selected.
(0000211)
thexa4 (developer)
2010-07-25 23:22

Could you provide a screenshot?
I am unable to reproduce this.
(0000212)
redj (administrator)
2010-07-25 23:30
edited on: 2010-07-25 23:31

see attached ide-select-all-broken.png

I'll compare my code to the version on the repository soon to confirm we're running the same code.

(0000280)
jerome (administrator)
2010-07-28 15:46

With redj's latest tarball, and a file that spans more than one screen, select all bring the cursor to the end of the page and leaves unselected text
(0000286)
thexa4 (developer)
2010-07-29 11:02

There was a problem with the cursor stays in view setting. Cursor will now not stay in view as long as there is a selection.
(0000315)
thexa4 (developer)
2010-08-07 14:14

Fixed by not keeping cursor in view if there is a selection:

Added revision 92 to /home/max/Desktop/ecere/repository/sdk/ecere/src/gui/controls/EditBox.ec

- Issue History
Date Modified Username Field Change
2010-02-25 15:25 thexa4 New Issue
2010-04-04 10:01 thexa4 Status new => assigned
2010-04-04 10:01 thexa4 Assigned To => thexa4
2010-04-04 14:21 thexa4 Status assigned => resolved
2010-04-04 14:21 thexa4 Resolution open => fixed
2010-04-04 14:21 thexa4 Note Added: 0000156
2010-07-07 04:20 redj Tag Attached: v0.44d2
2010-07-25 19:48 redj Status resolved => feedback
2010-07-25 19:48 redj Resolution fixed => reopened
2010-07-25 19:48 redj Note Added: 0000207
2010-07-25 19:49 redj Relationship added child of 0000429
2010-07-25 20:30 thexa4 Reproducibility always => unable to reproduce
2010-07-25 23:22 thexa4 Note Added: 0000211
2010-07-25 23:30 redj File Added: ide-select-all-broken.png
2010-07-25 23:30 redj Note Added: 0000212
2010-07-25 23:31 redj Note Edited: 0000212
2010-07-26 19:09 thexa4 Target Version => 0.44 draft 2
2010-07-26 20:17 redj Priority low => immediate
2010-07-28 15:46 jerome Note Added: 0000280
2010-07-28 15:47 jerome Severity minor => major
2010-07-28 15:47 jerome Reproducibility unable to reproduce => always
2010-07-28 15:47 jerome Status feedback => confirmed
2010-07-29 11:02 thexa4 Status confirmed => resolved
2010-07-29 11:02 thexa4 Fixed in Version => 0.44 draft 2
2010-07-29 11:02 thexa4 Resolution reopened => fixed
2010-07-29 11:02 thexa4 Note Added: 0000286
2010-08-07 14:14 thexa4 Note Added: 0000315
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:16 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker