View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000285Ecere SDKidepublic2009-11-22 19:532014-07-09 03:30
Reportermothdragon 
Assigned Tojerome 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000285: Resolution on Wide Screen Monitor causes minimization of window
DescriptionIn a class derived from GUIApplication, when setting resolution=res640x480 or any other resolution and fullscreen=true, the application minimizes to the start bar upon starting the application. When resuming the application by clicking on its name in the start bar the application may run normally, or may restore and minimize again immediately, but eventually will run normally. This only seems to be true on my widescreen monitor on my Gateway laptop. Running Windows XP Service Pack 2. This can be worked around by setting the size or clientSize of the Window derived class to the desired size, but obviously this doesn't change the resolution.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000992closedjerome Implement acquired input on X11 

-  Notes
(0000130)
mothdragon (reporter)
2009-11-22 20:11

I forgot to mention that I'm using the Tablet Edition of Windows XP and my default resolution is 1280x768
(0000131)
mothdragon (reporter)
2009-11-22 20:18

Further testing, proves that this issue only happens when the application is run from within the Ecere IDE.
(0001187)
jerome (administrator)
2014-02-19 15:52

This was caused by the debugging IDE being re-activated upon receiving a WM_DISPLAYCHANGE notification. I believe that particular issue was already fixed, but remaining issues such as coming back unmaximized if it was previously maximized was addressed by:

https://github.com/ecere/ecere-sdk/commit/2a9a3ae6df44c1a17d65136540cb29386e0f5e97 [^]
(0001360)
jerome (administrator)
2014-07-09 03:30

Corrected that last fix by:
https://github.com/ecere/ecere-sdk/commit/ec7476597149e60e272b295eeddf6a9655676b45 [^]

- Issue History
Date Modified Username Field Change
2009-11-22 19:53 mothdragon New Issue
2009-11-22 20:11 mothdragon Note Added: 0000130
2009-11-22 20:18 mothdragon Note Added: 0000131
2010-07-25 20:46 redj Relationship added child of 0000430
2012-03-08 16:52 redj Target Version => 0.45 Ginkakuji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2014-02-13 21:11 jerome Relationship added related to 0000992
2014-02-19 15:36 jerome Assigned To => jerome
2014-02-19 15:36 jerome Status new => assigned
2014-02-19 15:36 jerome Target Version 0.45 Ginkakuji => 0.44.10 64
2014-02-19 15:52 jerome Note Added: 0001187
2014-02-19 15:52 jerome Status assigned => resolved
2014-02-19 15:52 jerome Fixed in Version => 0.44.10 64
2014-02-19 15:52 jerome Resolution open => fixed
2014-05-19 01:33 jerome Status resolved => closed
2014-07-09 03:30 jerome Note Added: 0001360



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker