View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000280Ecere SDKidepublic2009-11-03 06:072013-05-19 22:15
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000280: Launching the IDE from an (empty) EPJ association stalls the IDE
DescriptionThe IDE never comes up but keeps running
Tagsstar, v0.44d2
Attached Files

- Relationships

-  Notes
(0000201)
redj (administrator)
2010-06-04 03:45

it's trying to create a MessageBox within the OnPostCreate of the IDE window. how can we go around that?
(0000230)
jerome (administrator)
2010-07-26 01:58

Where exactly does that hang?
The MessageBox 's Modal() should still run an event loop...

If all else fails we can perhaps move that MessageBox somewhere else than in OnPostCreate, e.g. in IDEApplication::Init() ?
(0000232)
redj (administrator)
2010-07-26 02:05

does that help?

  0 inside ntdll!LdrAccessResource, C:\WINDOWS\system32\ntdll.dll
  1 inside ntdll!ZwWaitForMultipleObjects, C:\WINDOWS\system32\ntdll.dll
  2 inside KERNEL32!CreateFileMappingA, C:\WINDOWS\system32\kernel32.dll
  3 inside USER32!GetLastInputInfo, C:\WINDOWS\system32\user32.dll
  4 inside USER32!MsgWaitForMultipleObjects, C:\WINDOWS\system32\user32.dll
  5 __ecereNameSpace__ecere__gui__drivers__Win32Interface_Wait Method, src\gui\drivers\Win32Interface.ec:1049
  6 __ecereNameSpace__ecere__gui__GuiApplication_Wait Method, src\gui\GuiApplication.ec:690
  7 __ecereNameSpace__ecere__gui__Window_DoModal Method, src\gui\Window.ec:6855
  8 __ecereNameSpace__ecere__gui__Window_Modal Method, src\gui\Window.ec:6212
  9 IDE_OpenFile Method, src\ide.ec:1467
 10 IDE_OnPostCreate Method, src\ide.ec:1994
 11 __ecereNameSpace__ecere__gui__Window_Create Method, src\gui\Window.ec:5972
 12 __ecereNameSpace__ecere__gui__GuiApplication_Main Method, src\gui\GuiApplication.ec:612
 13 main Function, obj\ide.debug.default.win32\ide.main.ec:3574
(0000238)
jerome (administrator)
2010-07-26 02:21

This means its waiting for a message, so a window should be up on the screen already at this point... Perhaps the problem is the 'master' relationship of that modal box not being presented yet? We should first try to fix it that way.
Looking at that MessageBox creation (maybe the CreateWindow failed because its master window was not yet shown?)
(0000513)
redj (administrator)
2012-03-07 06:11

touch empty.epj
ide empty.epj

no hang, no crash

under linux

same behavior under windows
this appears resolved

- Issue History
Date Modified Username Field Change
2009-11-03 06:07 jerome New Issue
2010-06-04 03:45 redj Note Added: 0000201
2010-07-07 02:37 redj Target Version => 0.44d2
2010-07-07 04:10 redj Tag Attached: v0.44d2
2010-07-07 04:44 redj Tag Attached: star
2010-07-25 20:48 redj Relationship added child of 0000429
2010-07-26 01:58 jerome Note Added: 0000230
2010-07-26 02:05 redj Note Added: 0000232
2010-07-26 02:21 jerome Note Added: 0000238
2010-07-26 19:18 thexa4 Target Version 0.44d2 => 0.44 draft 2
2012-03-07 06:11 redj Note Added: 0000513
2012-03-07 06:12 redj Status new => resolved
2012-03-07 06:12 redj Resolution open => fixed
2012-03-07 06:12 redj Assigned To => redj
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:19 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker