View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000240Ecere SDKidepublic2009-07-11 02:122014-05-19 01:33
Reportermothdragon 
Assigned Tojerome 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000240: Compiled Program automatically minimizes when fullScreen = true
DescriptionWhen using GuiApplication to set the screen mode of a program, strange things happen.

When fullScreen = true and resolution = res640x480, then the program flashes the resolution change, and then returns to the original resolution, minimizing the program automatically to the bar in Windows XP.

In Ubuntu 9.04 with the same settings, the resolution of the screen flashes, and then returns to normal, with the program amazingly absent altogether.
Additional InformationWindows XP is running on a widescreen laptop, Ubuntu is running on an archaic video card on a standard desktop..
TagsNo tags attached.
Attached Files

- Relationships
related to 0000992closedjerome Implement acquired input on X11 

-  Notes
(0001186)
jerome (administrator)
2014-02-19 15:52

This was caused by the debugging IDE being re-activated upon receiving a WM_DISPLAYCHANGE notification. I believe that particular issue was already fixed, but remaining issues such as coming back unmaximized if it was previously maximized was addressed by:

https://github.com/ecere/ecere-sdk/commit/2a9a3ae6df44c1a17d65136540cb29386e0f5e97 [^]

- Issue History
Date Modified Username Field Change
2009-07-11 02:12 mothdragon New Issue
2010-07-25 21:12 redj Relationship added child of 0000430
2012-03-08 16:52 redj Target Version => 0.45 Ginkakuji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2014-02-13 21:11 jerome Relationship added related to 0000992
2014-02-19 15:35 jerome Assigned To => jerome
2014-02-19 15:35 jerome Status new => assigned
2014-02-19 15:35 jerome Target Version 0.45 Ginkakuji => 0.44.10 64
2014-02-19 15:52 jerome Note Added: 0001186
2014-02-19 15:52 jerome Status assigned => resolved
2014-02-19 15:52 jerome Fixed in Version => 0.44.10 64
2014-02-19 15:52 jerome Resolution open => fixed
2014-05-19 01:33 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker