View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000234Ecere SDKcompilerpublic2009-07-03 19:462014-08-08 18:17
Reporterjerome 
Assigned Tojerome 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0000234: The SDK package fails to compile with GCC 3.4.5
DescriptioneSystem_Delete is invoked before being declared in a file

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001370)
jerome (administrator)
2014-07-11 07:40

This particular issue has been fixed with the proper topological sort:
https://github.com/ecere/ecere-sdk/commit/5165f9a12208bc4742da1914e53cb7ffe40199c2 [^]

Unfortunately, the tarball and generated Makefile won't build as is with MinGW/GCC 3.4.5 directly in the commandline because it seems it does not support the @objects.lst to handle long list of objects.

It will build however in MSYS.
(0001372)
jerome (administrator)
2014-07-11 08:51

Had to compensate for isblank missing with:
https://github.com/ecere/ecere-sdk/commit/2ae1b6c71825a012982d29c1a762e495c01e347a [^]

- Issue History
Date Modified Username Field Change
2009-07-03 19:46 jerome New Issue
2010-07-25 21:15 redj Relationship added child of 0000430
2012-03-08 16:51 redj Target Version => 0.45 Ginkakuji
2012-03-29 07:50 redj Category => eC Compiling Tools
2012-03-29 07:50 redj Project @2@ => Ecere SDK
2014-07-11 07:32 jerome Target Version 0.45 Ginkakuji => 0.44.10 64
2014-07-11 07:40 jerome Note Added: 0001370
2014-07-11 07:40 jerome Status new => resolved
2014-07-11 07:40 jerome Fixed in Version => 0.44.10 64
2014-07-11 07:40 jerome Resolution open => fixed
2014-07-11 07:40 jerome Assigned To => jerome
2014-07-11 08:51 jerome Note Added: 0001372
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker