View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000172Ecere SDKidepublic2009-05-03 05:522013-05-19 22:15
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000172: On closing file, take out modified star from project view
DescriptionOn closing file, take out modified star from project view
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000164)
redj (administrator)
2010-04-19 02:12

Implemented OnRequestClose vs OnClose
works like a charm!

Added revision 8 to ...\projects\games\poker\poker.ec
Added revision 7 to ...\projects\games\scrabble\scrabble.ec
Added revision 8 to ...\apps\chess\src\chess.ec
Added revision 27 to ...\apps\acovel\src\libraryView.ec
Added revision 3 to ...\apps\acovel\src\playList.ec
Added revision 12 to ...\apps\communicator\src\Communicator.ec
Added revision 5 to ...\sdk\samples\3D\rayTracedMandelbulb\mandelbulb.ec
Added revision 109 to ...\sdk\ecere\src\gui\Window.ec
Added revision 146 to ...\sdk\ide\src\ide.ec
Added revision 140 to ...\sdk\ide\src\designer\CodeEditor.ec
Added revision 15 to ...\sdk\ide\src\designer\Designer.ec
Added revision 43 to ...\sdk\ide\src\designer\Sheet.ec
Added revision 20 to ...\sdk\ide\src\designer\ToolBox.ec
Added revision 38 to ...\sdk\ide\src\dialogs\GlobalSettingsDialog.ec
Added revision 51 to ...\sdk\ide\src\dialogs\FindInFilesDialog.ec
Added revision 2 to ...\sdk\ide\src\dialogs\ProjectTabSettings.ec
Added revision 4 to ...\sdk\ide\src\dialogs\WorkspaceSettings.ec
Added revision 28 to ...\sdk\ide\src\panels\BreakpointsView.ec
Added revision 33 to ...\sdk\ide\src\panels\CallStackView.ec
Added revision 29 to ...\sdk\ide\src\panels\OutputView.ec
Added revision 26 to ...\sdk\ide\src\panels\ThreadsView.ec
Added revision 35 to ...\sdk\ide\src\panels\WatchesView.ec
Added revision 101 to ...\sdk\ide\src\project\ProjectView.ec
Added revision 79 to ...\sdk\ide\src\ProjectSettings.ec
Added revision 12 to ...\sdk\eda\libeda\src\gui.ec
Added revision 32 to ...\sdk\documentor\documentor.ec
(0000174)
jerome (administrator)
2010-04-19 11:56

Sorry don't mean to be unappreciative, but in all honesty I find this a little extreme.

I can read your anticipation of my feeling about this in your 'works like a charm!' :P

Can you explain me the difference between OnClose and OnRequestClose?

OnClose was already meant to be the 'request', whereas OnDestroy is called upon destruction of a Window.

I really wish we can revert those modifications to all those projects poker, scrabble, chess, libraryView!

Is this all about the 'hidden' debugger EditBox? btw we really need to find a better solution for that.
(0000176)
redj (administrator)
2010-04-19 14:04

hehe, actually "works like a charm!" was more from satisfaction or surprise that I could modify the events behavior that quickly with such obviously functional results.

I blame this one on lack of documentation but at least I did something instead of just waiting for an answer on how that should be fixed. The question was in the code for a long time.
(0000177)
redj (administrator)
2010-04-19 14:04

btw, I still think the increased granularity (OnRequestClose vs OnClose) could have been usefull but that depends on the calling order and details of all these events. on thing maybe worth nothing, my OnClose had a bool parentClosing parameter that is not available in OnDestroy which I'm using now to fix this issue.

Added revision 9 to ...\projects\games\poker\poker.ec
Added revision 8 to ...\projects\games\scrabble\scrabble.ec
Added revision 9 to ...\apps\chess\src\chess.ec
Added revision 28 to ...\apps\acovel\src\libraryView.ec
Added revision 4 to ...\apps\acovel\src\playList.ec
Added revision 13 to ...\apps\communicator\src\Communicator.ec
Added revision 6 to ...\sdk\samples\3D\rayTracedMandelbulb\mandelbulb.ec
Added revision 110 to ...\sdk\ecere\src\gui\Window.ec
Added revision 149 to ...\sdk\ide\src\ide.ec
Added revision 141 to ...\sdk\ide\src\designer\CodeEditor.ec
Added revision 16 to ...\sdk\ide\src\designer\Designer.ec
Added revision 44 to ...\sdk\ide\src\designer\Sheet.ec
Added revision 21 to ...\sdk\ide\src\designer\ToolBox.ec
Added revision 54 to ...\sdk\ide\src\dialogs\FindInFilesDialog.ec
Added revision 3 to ...\sdk\ide\src\dialogs\ProjectTabSettings.ec
Added revision 5 to ...\sdk\ide\src\dialogs\WorkspaceSettings.ec
Added revision 29 to ...\sdk\ide\src\panels\BreakpointsView.ec
Added revision 34 to ...\sdk\ide\src\panels\CallStackView.ec
Added revision 30 to ...\sdk\ide\src\panels\OutputView.ec
Added revision 27 to ...\sdk\ide\src\panels\ThreadsView.ec
Added revision 36 to ...\sdk\ide\src\panels\WatchesView.ec
Added revision 103 to ...\sdk\ide\src\project\ProjectView.ec
Added revision 80 to ...\sdk\ide\src\ProjectSettings.ec
Added revision 13 to ...\sdk\eda\libeda\src\gui.ec
Added revision 33 to ...\sdk\documentor\documentor.ec
(0000178)
jerome (administrator)
2010-04-19 16:13
edited on: 2010-04-19 16:14

I realize the API is far from perfect.
And the documentation is a number 1 problem, which I hope we will address soon :)

But let's please make changes to the API that breaks existing applications only after proper design review meetings that will decide and settle on what our proper API will be :)

Did you manage to fix the issue with the existing API? you're using OnClose and OnDestroy now?

And I'd like to learn more about your increased functionality/granularity to see if it is required and should be included in a new API.

(0000179)
redj (administrator)
2010-04-19 16:37

The issue is indeed marked as resolved (with the existing API - OnClose and OnDestroy, yes).

About the functionality/granularity of proposed OnRequestClose/OnClose, only a detailed study of the API will let us know how usefull that would be but it comes down to having the parentClosing parameter in the OnClose (now using OnDestroy where this param is not available) and the order in which things are called. The last improvement this API suggestion could give is clarity/orthogonality.
(0000181)
jerome (administrator)
2010-04-19 16:49

Good job :)

parentClosing is available in OnClose and it returns a bool because you still have a choice to stop the process, e.g. by hiding the window instead of destroying it.

In OnDestroy, you're being terminated. so it does not really matter whether the parent was closing or not, you're done with.

So I guess we'll have to sit down and understand the possible improvements here, and I should review the code to see how it turned out :) But not breaking compatibility with existing applications: me very happy.

I'm not sure whether Mantis supports the ! operator. You could also try the binary ~.

If you meant a 'note' though, you just scroll below the other notes and you should see an 'Add note' section (in which I'm typing right now), along with a centered 'Add Note' Button :)
(0000185)
redj (administrator)
2010-04-23 00:22

missed that little detail before
Added revision 39 to ...\sdk\ide\src\dialogs\GlobalSettingsDialog.ec
(0000186)
redj (administrator)
2010-04-23 00:50

don't mention it
Added revision 30 to ...\sdk\ide\src\panels\BreakpointsView.ec
Added revision 35 to ...\sdk\ide\src\panels\CallStackView.ec
Added revision 32 to ...\sdk\ide\src\panels\OutputView.ec
Added revision 28 to ...\sdk\ide\src\panels\ThreadsView.ec
Added revision 37 to ...\sdk\ide\src\panels\WatchesView.ec
(0000189)
redj (administrator)
2010-04-29 13:56
edited on: 2010-05-01 09:13

shh!
Added revision 22 to ...\sdk\ide\src\designer\ToolBox.ec
Added revision 142 to ...\sdk\ide\src\designer\CodeEditor.ec


- Issue History
Date Modified Username Field Change
2009-05-03 05:52 jerome New Issue
2009-05-03 06:30 jerome Status new => assigned
2009-05-03 06:30 jerome Assigned To => jerome
2010-04-19 02:11 redj Assigned To jerome => redj
2010-04-19 02:12 redj Status assigned => resolved
2010-04-19 02:12 redj Resolution open => fixed
2010-04-19 02:12 redj Note Added: 0000164
2010-04-19 11:56 jerome Note Added: 0000174
2010-04-19 14:04 redj Note Added: 0000176
2010-04-19 14:04 redj Status resolved => acknowledged
2010-04-19 14:04 redj Status acknowledged => resolved
2010-04-19 14:04 redj Note Added: 0000177
2010-04-19 16:13 jerome Note Added: 0000178
2010-04-19 16:14 jerome Note Edited: 0000178
2010-04-19 16:37 redj Status resolved => feedback
2010-04-19 16:37 redj Resolution fixed => reopened
2010-04-19 16:37 redj Note Added: 0000179
2010-04-19 16:38 redj Status feedback => resolved
2010-04-19 16:38 redj Resolution reopened => fixed
2010-04-19 16:38 redj Note Added: 0000180
2010-04-19 16:49 jerome Note Added: 0000181
2010-04-19 16:54 redj Status resolved => feedback
2010-04-19 16:54 redj Resolution fixed => reopened
2010-04-19 16:54 redj Note Added: 0000182
2010-04-19 16:54 redj Status feedback => resolved
2010-04-19 16:54 redj Resolution reopened => fixed
2010-04-19 17:22 jerome Note Added: 0000183
2010-04-23 00:22 redj Note Added: 0000185
2010-04-23 00:50 redj Note Added: 0000186
2010-04-23 02:39 redj Note Deleted: 0000180
2010-04-23 02:40 redj Note Deleted: 0000182
2010-04-23 02:40 redj Note Deleted: 0000183
2010-04-29 13:56 redj Note Added: 0000189
2010-05-01 04:04 redj Note Edited: 0000189
2010-05-01 09:13 redj Note Edited: 0000189
2010-07-07 02:38 redj Target Version => 0.44d2
2010-07-25 21:23 redj Relationship added child of 0000429
2010-07-26 19:24 thexa4 Target Version 0.44d2 => 0.44 draft 2
2012-03-08 15:33 redj Target Version old 0.44.pre2 => 0.44 Ryoan-ji
2012-03-08 17:23 redj Relationship deleted child of 0000429
2012-03-08 18:07 redj Fixed in Version => 0.44 Ryoan-ji
2012-03-29 07:52 redj Category => ide
2012-03-29 07:52 redj Project @3@ => Ecere SDK
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker