View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000145Ecere SDKecerepublic2009-01-09 02:592013-05-19 22:15
Reporterjoey 
Assigned Tojerome 
PriorityimmediateSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.44 Ryoan-jiFixed in Version0.44 Ryoan-ji 
Summary0000145: IDE StackOverflow due to link = SearchModule(subModule.module, name, listOffset, searchPrivate /*false*/); change
DescriptionOn my eMac, the IDE segfaults when this line in SearchModule says this:

link = SearchModule(subModule.module, name, listOffset, searchPrivate /*false*/);

instead of this:

link = SearchModule(subModule.module, name, listOffset, false);

The former line encounters infinite recursion which overflows the stack. The backtrace says stuff about WindowsSkin_DesignerBase and that the recursion is happening on this very line. See http://a-pastebin.co.cc/237 [^] .

CAN U PLZ FIXORS TIHS??? Hehe, jk. Have fun!
Tagsv0.44d2
Attached Files

- Relationships

-  Notes
(0000102)
jerome (administrator)
2009-01-09 03:15

This problem only happens when opening source files part of the ecere COM, when the ecereCOM shared library is available to be found. A mix up or conflict between ecere vs ecereCOM is happening with that searchPrivate and requires some attention. This is also likely purely an IDE live parser bug.
(0000103)
jerome (administrator)
2009-01-16 19:49

There is also a crash opening up gui.ec in EDA when ecereCOM.dll is present.
(0000256)
jerome (administrator)
2010-07-26 03:31

Definitely need to retry these scenarios in light of the most recent code base.
(0000577)
jerome (administrator)
2012-04-04 22:12

I believed we had fixed the issue(s) before.

We also reverted to 'false' instead of searchPrivate, as the comment in place in instance.ec says:


         // TOCHECK: Reverting to false to test what we were trying to fix by passing searchPrivate
         // Passing searchPrivate finds ALL classes private or not and thus classes clash
         // SearchModule here is called mainly from eSystem_FindClass, and also for Functions and Defines

         link = SearchModule(subModule.module, name, listOffset, false);
         //link = SearchModule(subModule.module, name, listOffset, searchPrivate /*false*/);

- Issue History
Date Modified Username Field Change
2009-01-09 02:59 joey New Issue
2009-01-09 03:15 jerome Note Added: 0000102
2009-01-16 19:49 jerome Note Added: 0000103
2009-04-08 22:30 jerome Status new => assigned
2009-04-08 22:30 jerome Assigned To => jerome
2009-05-03 06:48 jerome Priority urgent => immediate
2010-07-07 03:00 redj Target Version => 0.44d2
2010-07-07 04:10 redj Tag Attached: v0.44d2
2010-07-25 21:27 redj Relationship added child of 0000429
2010-07-26 03:31 jerome Note Added: 0000256
2010-07-26 03:32 jerome Summary IDE segfaults due to link = SearchModule(subModule.module, name, listOffset, searchPrivate /*false*/); change => IDE StackOverflow due to link = SearchModule(subModule.module, name, listOffset, searchPrivate /*false*/); change
2010-07-26 19:29 thexa4 Target Version 0.44d2 => 0.44 draft 2
2012-03-08 15:44 redj Target Version old 0.44.pre2 => 0.45 Ginkakuji
2012-03-08 17:31 redj Relationship deleted child of 0000429
2012-03-29 07:53 redj Category => Ecere Runtime Library
2012-03-29 07:53 redj Project @1@ => Ecere SDK
2012-04-04 22:12 jerome Status assigned => resolved
2012-04-04 22:12 jerome Fixed in Version => 0.44 Ryoan-ji
2012-04-04 22:12 jerome Resolution open => fixed
2012-04-04 22:12 jerome Note Added: 0000577
2012-04-07 18:32 redj Target Version 0.45 Ginkakuji => 0.44 Ryoan-ji
2013-05-19 22:15 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker