View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000125Ecere SDKecerepublic2008-08-22 20:312012-03-29 07:53
Reporterrohypnol 
Assigned Tojerome 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000125: Dragging text around with the mouse messes up Undo
DescriptionCan easily freeze the editor
Additional Information[Fri:16:36] <meow> so create a new project, select sizable, drag it after the ; on the next line (leaving a space between them)
[Fri:16:37] <meow> select activeBorder, put it in place of sizable
[Fri:16:37] <meow> i mean whee sizable used to be
[Fri:16:37] <meow> put sizable where activeBorder used to be
[Fri:16:37] <meow> and undo until the screen is empty
[Fri:16:37] <meow> then redo everything
[Fri:16:37] <meow> you'll get an extra "a"
TagsNo tags attached.
Attached Files

- Relationships
child of 0000433closed previously resolved issues (draft 1 of 0.44 and earlier) 

-  Notes
(0000084)
rohypnol (reporter)
2008-08-22 20:40

1) Create a new project
2) Select "activeBorder" and drag it so it looks like this:
   background = ;
   borderStyle = sizable; activeBorder
notice the space between ; and activeBorder
3) Select "sizable" and drag it so it looks like this:
   background = sizable;
   borderStyle = ; activeBorder
4) Select activeBorder and drag it so it looks like this:
   background = sizable;
   borderStyle = activeBorder;
you will have a trailing space after the second ;
5) Press and hold Ctrl+Z until the whole editor becomes empty
6) Press and hold Ctrl+Y until you get this:
   background = sizable;
   borderStyle = activeBorder;a
7) Notice there's an "a" on the second line that shouldn't be there
8) Profit!!!
(0000094)
jerome (administrator)
2008-08-29 21:22
edited on: 2008-08-29 21:41

This bug has been introduced by the fix for 0000123.
It has been solved in AddS by only limiting x1 when string[0] == '\n' :

if(string[0] == '\n')
   action = AddTextAction { y1 = y, x1 = Min(this.line.count, x), string = CopyString(string) };
else
   action = AddTextAction { y1 = y, x1 = x, string = CopyString(string) };

(Negative memory allocation was being done... BAD)

(0000095)
jerome (administrator)
2008-08-29 21:39

The particular issue with the a is still happening :(
(0000096)
jerome (administrator)
2008-08-29 22:05

Ok, maybe I should get some sleep. It *IS* working fine.
Must have been testing with a non compiled configuration...

- Issue History
Date Modified Username Field Change
2008-08-22 20:31 jerome New Issue
2008-08-22 20:31 jerome Status new => assigned
2008-08-22 20:31 jerome Assigned To => jerome
2008-08-22 20:36 jerome Reporter jerome => rohypnol
2008-08-22 20:36 jerome Additional Information Updated
2008-08-22 20:40 rohypnol Note Added: 0000084
2008-08-29 21:22 jerome Status assigned => resolved
2008-08-29 21:22 jerome Resolution open => fixed
2008-08-29 21:22 jerome Note Added: 0000094
2008-08-29 21:39 jerome Note Edited: 0000094
2008-08-29 21:39 jerome Note Added: 0000095
2008-08-29 21:39 jerome Status resolved => assigned
2008-08-29 21:41 jerome Note Edited: 0000094
2008-08-29 22:05 jerome Status assigned => resolved
2008-08-29 22:05 jerome Note Added: 0000096
2009-05-03 03:43 jerome Status resolved => closed
2010-07-25 21:29 redj Relationship added child of 0000429
2010-07-25 21:36 redj Relationship deleted child of 0000429
2010-07-25 21:36 redj Relationship added child of 0000433
2012-03-29 07:53 redj Category => Ecere Runtime Library
2012-03-29 07:53 redj Project @1@ => Ecere SDK



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker