View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001083Ecere SDKidepublic2014-06-14 09:062014-08-08 18:17
Reporterjerome 
Assigned Tojerome 
PriorityimmediateSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.09 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0001083: Stuck Tooltips, Stuck IDE, Crashing IDE
DescriptionToolTips remain stuck when hovering over them with some timing.
They keep the ide process stuck on exit if they were showing when closing the IDE.
That stuck IDE will crash on a GlobalSettings modified by new IDE instance e.g. on reloading the project.
Steps To Reproduce- Start up IDE
- Load up recent ide.epj
- Hover over Compiler, then right before tooltip comes hover over bit length, then right before it comes over on the IDE background (tooltips should stick)
- Exit (Stuck process)
- Startup new IDE, open recent ide.epj, old IDE will crash
  (Kept running due ToolTips or their tipped window keeping the main loop going, crashing on null toolBar when woken up by FileNotify on GlobalSettings)
Additional Information#0 0x00000000004f961d in __ecereMethod_IDEWorkSpace_UpdateToolBarActiveCompilers (this=0x2c11950) at src/ide.ec:1881
0000001 0x00000000004f9460 in __ecereMethod_IDEWorkSpace_UpdateCompilerConfigs (this=0x2c11950, mute=1) at src/ide.ec:1863
0000002 0x0000000000431b00 in __ecereInstMeth_IDESettingsContainer_OnLoad__00000000 (this=0x2733a80, data=0x2a776e0) at src/project/Project.ec:49
0000003 0x00000000005069ab in __ecereMethod_IDESettingsContainer_Load (this=0x2733a80) at src/IDESettings.ec:391
0000004 0x0000000000505f74 in __ecereMethod_IDESettingsContainer_OnAskReloadSettings (this=0x2733a80) at src/IDESettings.ec:294
0000005 0x00000000692d3435 in __ecereInstMeth___ecereNameSpace__ecere__sys__FileMonitor_OnFileNotify__00000000 (this=0x2733a80, action=4, param=0x0) at obj/release.win32.debug/GlobalAppSettings.c:19330
0000006 0x000000006941e3c3 in __ecereMethod___ecereNameSpace__ecere__gui__GuiApplication_ProcessFileNotifications (this=0x28ebd00) at obj/release.win32.debug/GuiApplication.c:21203
0000007 0x000000006941c895 in __ecereMethod___ecereNameSpace__ecere__gui__GuiApplication_ProcessInput (this=0x28ebd00, useProcessAll=1) at obj/release.win32.debug/GuiApplication.c:20521
0000008 0x000000006941c62c in __ecereMethod___ecereNameSpace__ecere__gui__GuiApplication_Main (this=0x28ebd00) at obj/release.win32.debug/GuiApplication.c:20463
0000009 0x0000000000410d67 in main (_argc=1, _argv=0x3e52e0) at obj/debug.win32/ide.main.ec:4459
TagsNo tags attached.
Attached Files

- Relationships
related to 0001084closedjerome project settings per-platform dir list edit crash in window.ec 

-  Notes
(0001334)
jerome (administrator)
2014-06-14 16:03

The problem seems to be that OnMouseLeave is never called.
(0001335)
jerome (administrator)
2014-06-14 16:14

It would seem this problem was introduced with:

https://github.com/ecere/ecere-sdk/commit/ab4dde3bdaf6541408ad30b6252c63ca4af5fa80 [^]
(0001336)
jerome (administrator)
2014-06-15 03:55

Fixed by:
https://github.com/ecere/ecere-sdk/commit/f5dce423a4a37aad19f2233c25836ed55d43b9b3 [^]
(0001343)
jerome (administrator)
2014-06-18 22:34

Further fixed (0001084) by:
https://github.com/ecere/ecere-sdk/commit/7c9dc5fd1f68f9e6c33bab17d3a3fc604fe7c8eb [^]

- Issue History
Date Modified Username Field Change
2014-06-14 09:06 jerome New Issue
2014-06-14 09:06 jerome Status new => assigned
2014-06-14 09:06 jerome Assigned To => jerome
2014-06-14 16:03 jerome Note Added: 0001334
2014-06-14 16:14 jerome Note Added: 0001335
2014-06-15 03:55 jerome Status assigned => resolved
2014-06-15 03:55 jerome Fixed in Version => 0.44.10 64
2014-06-15 03:55 jerome Resolution open => fixed
2014-06-15 03:55 jerome Note Added: 0001336
2014-06-18 22:01 jerome Relationship added related to 0001084
2014-06-18 22:34 jerome Note Added: 0001343
2014-08-08 18:17 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker