View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001014Ecere SDKidepublic2013-10-01 16:452013-10-09 07:00
Reporterjerome 
Assigned Toredj 
PriorityimmediateSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.44.09 
Target Version0.44.10 64Fixed in Version0.44.10 64 
Summary0001014: Confusion with the Expression/Value fields in the watch window
DescriptionTyping in Value Field of Watch window of a row without an expression should automatically switch to Expression field (or alternatively always switch right away to the expression field when on an empty row)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001114)
redj (administrator)
2013-10-05 13:36

fixed by <...>
(0001116)
jerome (administrator)
2013-10-05 15:07

The issue was about changing the active field (currentField in ListBox) back to the expression automatically upon changing row, not making the 'value' field not-editable :)

We still want it editable because we'll want to add support modify the value while debugging.
(0001117)
redj (administrator)
2013-10-05 16:17
edited on: 2013-10-09 06:57

Fixed by:
https://github.com/ecere/ecere-sdk/commit/cc15ed31e6123e0f6e960ba68e911200156f534d [^]


- Issue History
Date Modified Username Field Change
2013-10-01 16:45 jerome New Issue
2013-10-01 16:45 jerome Status new => assigned
2013-10-01 16:45 jerome Assigned To => redj
2013-10-05 13:36 redj Status assigned => resolved
2013-10-05 13:36 redj Fixed in Version => 0.44.10 64
2013-10-05 13:36 redj Resolution open => fixed
2013-10-05 13:36 redj Note Added: 0001114
2013-10-05 15:07 jerome Note Added: 0001116
2013-10-05 15:07 jerome Status resolved => assigned
2013-10-05 16:17 redj Note Added: 0001117
2013-10-05 16:17 redj Status assigned => resolved
2013-10-09 06:57 jerome Note Edited: 0001117
2013-10-09 07:00 jerome Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker